blob: ed792b1c7ed17d9e021e3e948ce5a76fc034e026 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Universal encoding detector for Python 2 and 3"
2HOMEPAGE = "https://pypi.org/project/chardet/"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
5
Patrick Williams2a254922023-08-11 09:48:11 -05006SRC_URI[sha256sum] = "1b3b6ff479a8c414bc3fa2c0852995695c4a026dcd6d0633b2dd092ca39c1cf7"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8# setup.py of chardet needs this.
Patrick Williams73bd93f2024-02-20 08:07:48 -06009DEPENDS += "python3-pytest-runner-native"
Andrew Geissler517393d2023-01-13 08:55:19 -060010
11inherit pypi python_setuptools_build_meta
12
13PACKAGES =+ "${PN}-cli"
14FILES:${PN}-cli += " \
15 ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
16"
17
18RDEPENDS:${PN}-cli = "${PN} "
19
20RDEPENDS:${PN}:class-target += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060021 python3-logging \
Andrew Geissler517393d2023-01-13 08:55:19 -060022"
23
24BBCLASSEXTEND = "native nativesdk"