blob: 8fd6583104be74debc063658afcc450369ceceeb [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A GObject-based Exiv2 wrapper"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=625f055f41728f84a8d7938acc35bdc2"
4
5DEPENDS = "exiv2 python3-pygobject-native"
6
Andrew Geissler595f6302022-01-24 19:11:47 +00007GTKDOC_MESON_OPTION = "gtk_doc"
8
Andrew Geissler220dafd2023-10-04 10:18:08 -05009inherit gnomebase gobject-introspection gtk-doc python3native vala
Andrew Geissler595f6302022-01-24 19:11:47 +000010
Andrew Geissler220dafd2023-10-04 10:18:08 -050011SRC_URI[archive.sha256sum] = "2a0c9cf48fbe8b3435008866ffd40b8eddb0667d2212b42396fdf688e93ce0be"
Andrew Geissler595f6302022-01-24 19:11:47 +000012
13EXTRA_OEMESON = " \
Andrew Geissler220dafd2023-10-04 10:18:08 -050014 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-Dvapi=true', '-Dvapi=false', d)} \
Andrew Geissler595f6302022-01-24 19:11:47 +000015"
16
17PACKAGES =+ "${PN}-python3"
18FILES:${PN}-python3 = "${PYTHON_SITEPACKAGES_DIR}"
19RDEPENDS:${PN}-python3 = "${PN}"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050020
21PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
22src_package_preprocess () {
23 # Trim build paths from comments in generated sources to ensure reproducibility
24 sed -i -e "s,${B}/../${BPN}-${PV}/${BPN}/,,g" \
25 ${B}/gexiv2/gexiv2-enums.cpp
26}
Patrick Williamsac13d5f2023-11-24 18:59:46 -060027
28do_install:append() {
29 # gexiv2 harcodes usr/lib as install path, so this corrects it to actual libdir
30 if [ "${prefix}/lib" != "${libdir}" ]; then
31 mv ${D}/${prefix}/lib/* ${D}/${libdir}/
32 rm -rf ${D}/${prefix}/lib
33 fi
34}