Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "A GObject-based Exiv2 wrapper" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 2 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=625f055f41728f84a8d7938acc35bdc2" |
| 4 | |
| 5 | DEPENDS = "exiv2 python3-pygobject-native" |
| 6 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 7 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 8 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 9 | inherit gnomebase gobject-introspection gtk-doc python3native vala |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 11 | SRC_URI[archive.sha256sum] = "2a0c9cf48fbe8b3435008866ffd40b8eddb0667d2212b42396fdf688e93ce0be" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | |
| 13 | EXTRA_OEMESON = " \ |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 14 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-Dvapi=true', '-Dvapi=false', d)} \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | PACKAGES =+ "${PN}-python3" |
| 18 | FILES:${PN}-python3 = "${PYTHON_SITEPACKAGES_DIR}" |
| 19 | RDEPENDS:${PN}-python3 = "${PN}" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 20 | |
| 21 | PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess" |
| 22 | src_package_preprocess () { |
| 23 | # Trim build paths from comments in generated sources to ensure reproducibility |
| 24 | sed -i -e "s,${B}/../${BPN}-${PV}/${BPN}/,,g" \ |
| 25 | ${B}/gexiv2/gexiv2-enums.cpp |
| 26 | } |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 27 | |
| 28 | do_install:append() { |
| 29 | # gexiv2 harcodes usr/lib as install path, so this corrects it to actual libdir |
| 30 | if [ "${prefix}/lib" != "${libdir}" ]; then |
| 31 | mv ${D}/${prefix}/lib/* ${D}/${libdir}/ |
| 32 | rm -rf ${D}/${prefix}/lib |
| 33 | fi |
| 34 | } |