Matt Spinler | eea390f | 2017-08-14 13:27:09 -0500 | [diff] [blame] | 1 | SUMMARY = "Witherspoon Power Fault Analysis" |
| 2 | DESCRIPTION = "Analyzes power devices for faults" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit autotools |
| 6 | inherit pkgconfig |
| 7 | inherit obmc-phosphor-systemd |
| 8 | inherit pythonnative |
| 9 | |
| 10 | require ${PN}.inc |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | DEPENDS += " \ |
| 15 | phosphor-logging \ |
| 16 | autoconf-archive-native \ |
| 17 | sdbus++-native \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN} += " \ |
| 21 | phosphor-logging \ |
| 22 | phosphor-dbus-interfaces \ |
| 23 | sdbusplus \ |
| 24 | " |
| 25 | |
| 26 | CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target" |
| 27 | SEQ_PGOOD_SVC = "witherspoon-pseq-monitor-pgood.service" |
| 28 | SEQ_PGOOD_FMT = "../${SEQ_PGOOD_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_PGOOD_SVC}" |
| 29 | |
Matt Spinler | bbd7845 | 2017-09-07 12:38:14 -0500 | [diff] [blame] | 30 | SYSTEMD_SERVICE_${PN} += "${SEQ_PGOOD_SVC}" |
| 31 | SYSTEMD_LINK_${PN} += "${SEQ_PGOOD_FMT}" |