Adriana Kobylak | 2493fdb | 2019-05-02 09:54:20 -0500 | [diff] [blame] | 1 | FILESEXTRAPATHS_append := ":${THISDIR}/${PN}" |
Matthew Barth | a63359e | 2019-04-12 13:20:39 -0500 | [diff] [blame] | 2 | # Machine specific files override shared files with the same name |
| 3 | FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 4 | |
| 5 | # Package configuration |
| 6 | FAN_PACKAGES += " \ |
| 7 | phosphor-cooling-type \ |
| 8 | " |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 9 | |
| 10 | PACKAGECONFIG += "cooling-type" |
| 11 | |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 12 | TMPL_COOLING = "phosphor-cooling-type@.service" |
| 13 | INSTFMT_COOLING = "phosphor-cooling-type@{0}.service" |
Patrick Venture | 85cff8c | 2019-04-04 13:06:43 -0700 | [diff] [blame] | 14 | COOLING_TGT = "multi-user.target" |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 15 | FMT_COOLING = "../${TMPL_COOLING}:${COOLING_TGT}.requires/${INSTFMT_COOLING}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 16 | |
Patrick Venture | 8c065e2 | 2019-03-30 08:57:39 -0700 | [diff] [blame] | 17 | FILES_phosphor-cooling-type = "${bindir}/phosphor-cooling-type" |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 18 | SYSTEMD_SERVICE_phosphor-cooling-type += "${TMPL_COOLING}" |
| 19 | SYSTEMD_LINK_phosphor-cooling-type += "${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 20 | |
| 21 | COOLING_ENV_FMT = "obmc/phosphor-fan/phosphor-cooling-type-{0}.conf" |
| 22 | |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 23 | SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type += "${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 24 | |
Matthew Barth | ceacb77 | 2017-10-24 14:07:09 -0500 | [diff] [blame] | 25 | #These services are protected by the watchdog |
Matthew Barth | 2eb5a13 | 2019-04-12 13:43:18 -0500 | [diff] [blame] | 26 | SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control-init@0.service.d/fan-watchdog-monitor.conf" |
| 27 | SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf" |
| 28 | SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf" |
| 29 | SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf" |
Matt Spinler | d9aee4a | 2017-06-19 14:55:52 -0500 | [diff] [blame] | 30 | |
Matthew Barth | ceacb77 | 2017-10-24 14:07:09 -0500 | [diff] [blame] | 31 | #These services need to be stopped when watchdog expires |
Matthew Barth | 2eb5a13 | 2019-04-12 13:43:18 -0500 | [diff] [blame] | 32 | SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf" |
| 33 | SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf" |