Matt Spinler | 17de1eb | 2017-06-06 09:40:45 -0500 | [diff] [blame] | 1 | SUMMARY = "Witherspoon fan watchdog services" |
| 2 | PR = "r1" |
Patrick Venture | 232b5bd | 2018-11-05 20:20:14 -0800 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Matt Spinler | 17de1eb | 2017-06-06 09:40:45 -0500 | [diff] [blame] | 5 | |
Matt Spinler | 17de1eb | 2017-06-06 09:40:45 -0500 | [diff] [blame] | 6 | inherit obmc-phosphor-systemd |
| 7 | |
Gunnar Mills | 7460b22 | 2017-07-10 15:49:43 -0500 | [diff] [blame] | 8 | RDEPENDS_${PN} += "virtual/obmc-gpio-monitor" |
Matt Spinler | 796f28d | 2017-06-13 15:57:04 -0500 | [diff] [blame] | 9 | RDEPENDS_${PN} += "busybox" |
Matt Spinler | 17de1eb | 2017-06-06 09:40:45 -0500 | [diff] [blame] | 10 | |
| 11 | RESET_SERVICE = "witherspoon-reset-fan-watchdog.service" |
| 12 | TGTFMT = "obmc-chassis-poweron@0.target" |
| 13 | RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}" |
| 14 | |
Matt Spinler | 9bce4f8 | 2017-06-08 12:46:22 -0500 | [diff] [blame] | 15 | MONITOR_SERVICE = "witherspoon-fan-watchdog-monitor@.service" |
| 16 | |
Matt Spinler | 796f28d | 2017-06-13 15:57:04 -0500 | [diff] [blame] | 17 | WATCHDOG_SERVICE = "witherspoon-fan-watchdog.service" |
| 18 | WATCHDOG_FMT = "../${WATCHDOG_SERVICE}:${TGTFMT}.requires/${WATCHDOG_SERVICE}" |
| 19 | |
| 20 | SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE} ${WATCHDOG_SERVICE}" |
| 21 | SYSTEMD_LINK_${PN} += "${RESET_FMT} ${WATCHDOG_FMT}" |
| 22 | SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/witherspoon-fan-watchdog/reset-fan-watchdog.conf" |
| 23 | SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/witherspoon-fan-watchdog/fan-watchdog.conf" |