Brad Bishop | 6587e6c | 2019-05-13 14:46:48 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 2 | |
| 3 | # Package configuration |
Brad Bishop | bb0e1d0 | 2019-07-17 17:35:55 -0400 | [diff] [blame] | 4 | FAN_PACKAGES_append_ibm-ac-server = " \ |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 5 | phosphor-cooling-type \ |
Ben_Pai | 949f914 | 2019-08-05 18:34:34 +0800 | [diff] [blame] | 6 | " |
| 7 | |
| 8 | FAN_PACKAGES_append_mihawk = " \ |
| 9 | phosphor-cooling-type \ |
| 10 | " |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 11 | |
Brad Bishop | bb0e1d0 | 2019-07-17 17:35:55 -0400 | [diff] [blame] | 12 | PACKAGECONFIG_append_ibm-ac-server = " cooling-type" |
Ben_Pai | 949f914 | 2019-08-05 18:34:34 +0800 | [diff] [blame] | 13 | PACKAGECONFIG_append_mihawk = " cooling-type" |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 14 | |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 15 | TMPL_COOLING = "phosphor-cooling-type@.service" |
| 16 | INSTFMT_COOLING = "phosphor-cooling-type@{0}.service" |
Matthew Barth | f59761e | 2019-09-20 09:56:35 -0500 | [diff] [blame] | 17 | MULTI_USR_TGT = "multi-user.target" |
| 18 | FMT_COOLING = "../${TMPL_COOLING}:${MULTI_USR_TGT}.requires/${INSTFMT_COOLING}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 19 | |
Brad Bishop | bb0e1d0 | 2019-07-17 17:35:55 -0400 | [diff] [blame] | 20 | FILES_phosphor-cooling-type_append_ibm-ac-server = " ${bindir}/phosphor-cooling-type" |
| 21 | SYSTEMD_SERVICE_phosphor-cooling-type_append_ibm-ac-server = " ${TMPL_COOLING}" |
| 22 | SYSTEMD_LINK_phosphor-cooling-type_append_ibm-ac-server = " ${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}" |
Ben_Pai | 949f914 | 2019-08-05 18:34:34 +0800 | [diff] [blame] | 23 | FILES_phosphor-cooling-type_append_mihawk = " ${bindir}/phosphor-cooling-type" |
| 24 | SYSTEMD_SERVICE_phosphor-cooling-type_append_mihawk = " ${TMPL_COOLING}" |
| 25 | SYSTEMD_LINK_phosphor-cooling-type_append_mihawk = " ${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 26 | |
| 27 | COOLING_ENV_FMT = "obmc/phosphor-fan/phosphor-cooling-type-{0}.conf" |
| 28 | |
Brad Bishop | bb0e1d0 | 2019-07-17 17:35:55 -0400 | [diff] [blame] | 29 | SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type_append_ibm-ac-server = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}" |
Ben_Pai | 949f914 | 2019-08-05 18:34:34 +0800 | [diff] [blame] | 30 | SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type_append_mihawk = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 31 | |
Matthew Barth | ceacb77 | 2017-10-24 14:07:09 -0500 | [diff] [blame] | 32 | #These services are protected by the watchdog |
Matthew Barth | 2eb5a13 | 2019-04-12 13:43:18 -0500 | [diff] [blame] | 33 | SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf" |
| 34 | SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf" |
| 35 | SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf" |
Matt Spinler | d9aee4a | 2017-06-19 14:55:52 -0500 | [diff] [blame] | 36 | |
Matthew Barth | ceacb77 | 2017-10-24 14:07:09 -0500 | [diff] [blame] | 37 | #These services need to be stopped when watchdog expires |
Matthew Barth | 2eb5a13 | 2019-04-12 13:43:18 -0500 | [diff] [blame] | 38 | SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf" |
| 39 | SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf" |
Matthew Barth | f59761e | 2019-09-20 09:56:35 -0500 | [diff] [blame] | 40 | |
| 41 | # Remove fan control init service completely |
| 42 | SYSTEMD_SERVICE_${PN}-control_remove_witherspoon = "${TMPL_CONTROL_INIT}" |
| 43 | SYSTEMD_LINK_${PN}-control_remove_witherspoon = "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHASSIS_INSTANCES')}" |
| 44 | # Remove fan control from being linked |
| 45 | SYSTEMD_LINK_${PN}-control_remove_witherspoon = "${@compose_list(d, 'FMT_CONTROL', 'OBMC_CHASSIS_INSTANCES')}" |
| 46 | |
| 47 | # Link fan control service to be started at standby |
| 48 | FMT_CONTROL_STDBY_witherspoon = "../${TMPL_CONTROL}:${MULTI_USR_TGT}.wants/${INSTFMT_CONTROL}" |
| 49 | SYSTEMD_LINK_${PN}-control_witherspoon += "${@compose_list(d, 'FMT_CONTROL_STDBY', 'OBMC_CHASSIS_INSTANCES')}" |
| 50 | # Link fan control service to also start at poweron |
| 51 | FMT_CONTROL_PWRON_witherspoon = "../${TMPL_CONTROL}:${POWERON_TGT}.requires/${INSTFMT_CONTROL}" |
| 52 | SYSTEMD_LINK_${PN}-control_witherspoon += "${@compose_list(d, 'FMT_CONTROL_PWRON', 'OBMC_CHASSIS_INSTANCES')}" |
Matthew Barth | a6817ca | 2020-01-14 14:21:46 -0600 | [diff] [blame] | 53 | |
| 54 | # Enable the use of JSON on the fan applications that support it |
| 55 | EXTRA_OECONF_append_witherspoon = " --enable-json" |
| 56 | RDEPENDS_${PN}-presence-tach_append_witherspoon = " phosphor-fan-presence-config" |