Brad Bishop | 6587e6c | 2019-05-13 14:46:48 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
Matthew Barth | 3620680 | 2020-06-19 13:48:27 -0500 | [diff] [blame] | 2 | |
Matthew Barth | 27be42e | 2020-06-22 11:14:20 -0500 | [diff] [blame] | 3 | SRC_URI_witherspoon = "file://config.json" |
Matthew Barth | dd3117e | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 4 | SRC_URI_rainier = "file://rainier-2u/config.json \ |
| 5 | file://rainier-4u/config.json \ |
| 6 | file://everest/config.json \ |
| 7 | " |
Matthew Barth | 3620680 | 2020-06-19 13:48:27 -0500 | [diff] [blame] | 8 | |
Matthew Barth | 27be42e | 2020-06-22 11:14:20 -0500 | [diff] [blame] | 9 | do_install_witherspoon() { |
Matthew Barth | 3620680 | 2020-06-19 13:48:27 -0500 | [diff] [blame] | 10 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ |
| 11 | install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ |
| 12 | } |
| 13 | |
Matthew Barth | dd3117e | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 14 | do_install_rainier() { |
| 15 | # Install Rainier-2U/4U fan monitor config files |
| 16 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/ |
| 17 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/ |
| 18 | install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/ |
| 19 | install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/ |
| 20 | |
| 21 | # Install Everest fan monitor config file |
| 22 | install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/ |
| 23 | install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/ |
| 24 | } |
| 25 | |
Matthew Barth | 27be42e | 2020-06-22 11:14:20 -0500 | [diff] [blame] | 26 | FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json" |
| 27 | FILES_${PN}_remove_witherspoon = "${monitor_datadir}/monitor.yaml" |
Matthew Barth | dd3117e | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 28 | |
| 29 | FILES_${PN}_remove_rainier = "${monitor_datadir}/monitor.yaml" |
| 30 | FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/config.json" |
| 31 | FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/config.json" |
| 32 | FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/monitor/ibm,everest/config.json" |