Brad Bishop | 6587e6c | 2019-05-13 14:46:48 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
Matthew Barth | a6817ca | 2020-01-14 14:21:46 -0600 | [diff] [blame] | 2 | |
| 3 | SRC_URI_witherspoon = "file://config.json" |
Matthew Barth | dd3117e | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 4 | SRC_URI_rainier = "file://rainier-2u/config.json \ |
| 5 | file://rainier-4u/config.json \ |
| 6 | file://everest/config.json \ |
| 7 | " |
Matthew Barth | a6817ca | 2020-01-14 14:21:46 -0600 | [diff] [blame] | 8 | |
| 9 | do_install_witherspoon() { |
| 10 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ |
| 11 | install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ |
| 12 | } |
Matthew Barth | dd3117e | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 13 | do_install_rainier() { |
| 14 | # Install Rainier-2U/4U fan presence config files |
| 15 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/ |
| 16 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/ |
| 17 | install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/ |
| 18 | install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/ |
| 19 | |
| 20 | # Install Everest fan presence config file |
| 21 | install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/ |
| 22 | install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/ |
| 23 | } |
Matthew Barth | a6817ca | 2020-01-14 14:21:46 -0600 | [diff] [blame] | 24 | |
| 25 | FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json" |
| 26 | FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml" |
Matthew Barth | dd3117e | 2020-11-23 19:40:56 -0600 | [diff] [blame] | 27 | |
| 28 | FILES_${PN}_remove_rainier = "${presence_datadir}/config.yaml" |
| 29 | FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json" |
| 30 | FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json" |
| 31 | FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json" |