Brad Bishop | fd327fb | 2017-01-17 09:21:15 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands" |
| 2 | DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands" |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 3 | HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools pkgconfig |
| 7 | inherit obmc-phosphor-license |
Tom Joseph | df68650 | 2017-02-01 19:47:27 +0530 | [diff] [blame^] | 8 | inherit obmc-phosphor-ipmiprovider-symlink |
| 9 | inherit obmc-phosphor-utils |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 10 | |
Brad Bishop | 80e7f90 | 2017-01-17 10:07:14 -0500 | [diff] [blame] | 11 | DEPENDS += "phosphor-ipmi-host" |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 12 | DEPENDS += "autoconf-archive-native" |
| 13 | |
| 14 | TARGET_CFLAGS += "-fpic" |
| 15 | |
| 16 | SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem" |
| 17 | SRCREV = "70dbc5871c6da23f7f14046ce9d356600992f6a8" |
| 18 | |
Tom Joseph | df68650 | 2017-02-01 19:47:27 +0530 | [diff] [blame^] | 19 | HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so" |
| 20 | |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 21 | S = "${WORKDIR}/git" |
| 22 | |
Tom Joseph | df68650 | 2017-02-01 19:47:27 +0530 | [diff] [blame^] | 23 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
Brad Bishop | 07ffcce | 2017-01-17 09:18:39 -0500 | [diff] [blame] | 24 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
Tom Joseph | df68650 | 2017-02-01 19:47:27 +0530 | [diff] [blame^] | 25 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |