Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
| 3 | HOMEPAGE = "http://github.com/openbmc/sdbusplus" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
| 8 | inherit autotools pkgconfig |
Patrick Williams | 5818530 | 2016-11-22 07:01:14 -0600 | [diff] [blame] | 9 | inherit obmc-phosphor-python-autotools |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 10 | |
| 11 | DEPENDS += "autoconf-archive-native" |
| 12 | RDEPENDS_${PN} += " \ |
| 13 | python-inflection \ |
| 14 | python-mako \ |
| 15 | python-pyyaml \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI += "git://github.com/openbmc/sdbusplus" |
Patrick Williams | e282e0f | 2016-12-05 10:50:02 -0600 | [diff] [blame] | 19 | SRCREV = "7904ed64341334649a5c613f7007a449d6899508" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 20 | |
| 21 | PACKAGECONFIG ??= "libsdbusplus" |
| 22 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
Patrick Williams | 2979202 | 2016-11-22 11:05:11 -0600 | [diff] [blame] | 26 | PROVIDES_prepend = "sdbus++ " |
| 27 | PACKAGES_prepend = "sdbus++ " |
| 28 | FILES_sdbus++_append = " ${bindir}/sdbus++" |
| 29 | PYTHON_AUTOTOOLS_PACKAGE = "sdbus++" |
| 30 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 31 | PACKAGECONFIG_remove_class-native = "libsdbusplus" |
| 32 | PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus" |
Patrick Williams | 8b0bd1f | 2016-11-22 13:28:33 -0600 | [diff] [blame] | 33 | ALLOW_EMPTY_${PN} = "1" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 34 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 35 | BBCLASSEXTEND += "native nativesdk" |