blob: b113ba4032ea6f4243c62b0523838ffc407b35b5 [file] [log] [blame]
Brad Bishop30f78552017-01-28 12:51:42 -05001SUMMARY = "Sample inventory map for phosphor-ipmi-fru"
2PR = "r1"
Patrick Venture4836bb72018-10-26 09:56:15 -07003PV = "1.0+git${SRCPV}"
Brad Bishop30f78552017-01-28 12:51:42 -05004
5inherit native
6inherit phosphor-ipmi-fru
7
8require phosphor-ipmi-fru.inc
9
10PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
11
12S = "${WORKDIR}/git"
13
14do_install() {
Patrick Williams70a568d2017-02-09 12:20:09 -060015 # TODO: install this to inventory_datadir
16 # after ipmi-fru-parser untangles the host
17 # firmware config from the machine inventory.
18 DEST=${D}${config_datadir}
Brad Bishop30f78552017-01-28 12:51:42 -050019 install -d ${DEST}
Patrick Williams70a568d2017-02-09 12:20:09 -060020 install scripts/example.yaml ${DEST}/config.yaml
Brad Bishop30f78552017-01-28 12:51:42 -050021}