blob: d1fa6396de46e7e6f8d9bf89da198fd3665c7aed [file] [log] [blame]
Adriana Kobylak2ca101c2016-01-30 08:53:35 -06001SUMMARY = "Settings DBUS object"
2DESCRIPTION = "Settings DBUS object"
3HOMEPAGE = "http://github.com/openbmc/phosphor-settingsd"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8
9RDEPENDS_${PN} += "python-dbus python-pygobject"
10
11SRC_URI += "git://github.com/openbmc/phosphor-settingsd"
12
Adriana Kobylak3355b092016-02-01 21:58:55 -060013SRCREV = "3bda531d94f4c93473bbedd7d7e5c44d4d9da93b"
Adriana Kobylak2ca101c2016-01-30 08:53:35 -060014
15S = "${WORKDIR}/git"
16
17do_install() {
18 install -d ${D}/${sbindir}
19 install ${S}/settings_file.py ${D}/${sbindir}
20 install ${S}/settings_manager.py ${D}/${sbindir}
21}
22