Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
| 3 | HOMEPAGE = "http://github.com/openbmc/sdbusplus" |
| 4 | PR = "r1" |
Patrick Venture | 66d1584 | 2018-10-17 07:19:55 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 8 | |
| 9 | inherit autotools pkgconfig |
Patrick Williams | 5818530 | 2016-11-22 07:01:14 -0600 | [diff] [blame] | 10 | inherit obmc-phosphor-python-autotools |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 11 | |
Nagaraju Goruganti | 78077a5 | 2017-08-22 05:24:26 -0500 | [diff] [blame] | 12 | DEPENDS += " \ |
| 13 | autoconf-archive-native \ |
| 14 | python-inflection-native \ |
| 15 | python-mako-native \ |
| 16 | python-pyyaml-native \ |
| 17 | " |
Brad Bishop | 29dc870 | 2017-01-12 14:06:43 -0500 | [diff] [blame] | 18 | RDEPENDS_sdbus++ += " \ |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 19 | python-inflection \ |
| 20 | python-mako \ |
| 21 | python-pyyaml \ |
| 22 | " |
| 23 | |
Brad Bishop | 32f0a9a | 2017-01-18 13:59:33 -0500 | [diff] [blame] | 24 | # sdbus++ has a handful of runtime dependencies on other python packages. |
| 25 | # Bitbake doesn't do anything with RDEPENDS in native context because |
| 26 | # native context doesn't have packages. |
| 27 | # |
| 28 | # While technically sdbus++ doesn't require its runtime dependencies to be |
| 29 | # installed to build, work around the above native context behavior |
| 30 | # by adding a build dependency so that clients don't have to DEPEND |
| 31 | # on sdbus++ runtime dependencies manually. |
| 32 | |
| 33 | DEPENDS_append_class-native = " \ |
| 34 | python-inflection-native \ |
| 35 | python-mako-native \ |
| 36 | python-pyyaml-native \ |
| 37 | " |
| 38 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 39 | SRC_URI += "git://github.com/openbmc/sdbusplus" |
Andrew Geissler | 3154238 | 2018-10-30 20:10:16 +0000 | [diff] [blame] | 40 | SRCREV = "6b4fb2969cd0c853ff6aa7f9bdd3ddaa0081c204" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 41 | |
Adriana Kobylak | 178d6b5 | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 42 | PACKAGECONFIG ??= "libsdbusplus transaction" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 43 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
Adriana Kobylak | 178d6b5 | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 44 | PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 45 | |
| 46 | S = "${WORKDIR}/git" |
| 47 | |
Patrick Williams | 2979202 | 2016-11-22 11:05:11 -0600 | [diff] [blame] | 48 | PROVIDES_prepend = "sdbus++ " |
Brad Bishop | cc01d1a | 2018-02-27 00:30:06 -0500 | [diff] [blame] | 49 | PACKAGE_BEFORE_PN = "sdbus++" |
Patrick Williams | 2979202 | 2016-11-22 11:05:11 -0600 | [diff] [blame] | 50 | FILES_sdbus++_append = " ${bindir}/sdbus++" |
| 51 | PYTHON_AUTOTOOLS_PACKAGE = "sdbus++" |
| 52 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 53 | PACKAGECONFIG_remove_class-native = "libsdbusplus" |
| 54 | PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus" |
| 55 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 56 | BBCLASSEXTEND += "native nativesdk" |