Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor Settings Manager" |
| 2 | DESCRIPTION = "Phosphor Settings Manager is an application that creates \ |
| 3 | d-bus objects to represent various user settings." |
| 4 | PR = "r1" |
Patrick Venture | 5c24f79 | 2018-10-26 08:55:27 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 6 | |
| 7 | inherit autotools |
| 8 | inherit obmc-phosphor-dbus-service |
| 9 | inherit pythonnative |
| 10 | inherit phosphor-settings-manager |
| 11 | |
| 12 | require phosphor-settings-manager.inc |
| 13 | |
| 14 | DBUS_SERVICE_${PN} = "xyz.openbmc_project.Settings.service" |
| 15 | |
| 16 | DEPENDS += "python-pyyaml-native" |
| 17 | DEPENDS += "python-mako-native" |
| 18 | DEPENDS += "autoconf-archive-native" |
| 19 | DEPENDS += "virtual/phosphor-settings-defaults" |
Brad Bishop | 7a17b6b | 2018-03-08 22:29:25 -0500 | [diff] [blame] | 20 | DEPENDS += "${@df_enabled(d, 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native')}" |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 21 | DEPENDS += "sdbusplus sdbusplus-native" |
| 22 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Brad Bishop | fb3c860 | 2017-07-30 20:33:06 -0400 | [diff] [blame] | 23 | DEPENDS += "phosphor-logging" |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 24 | DEPENDS += "libcereal" |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 25 | |
| 26 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| 27 | |
| 28 | S = "${WORKDIR}/git" |
Deepak Kodihalli | 51b3d16 | 2017-07-23 14:08:56 -0500 | [diff] [blame] | 29 | SRC_URI += "file://merge_settings.py" |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 30 | |
| 31 | EXTRA_OECONF = " \ |
| 32 | SETTINGS_YAML=${STAGING_DIR_NATIVE}${settings_datadir}/defaults.yaml \ |
| 33 | " |
Deepak Kodihalli | 51b3d16 | 2017-07-23 14:08:56 -0500 | [diff] [blame] | 34 | |
| 35 | # Collect files in SRC_URI that end in ".override.yml" and call a script that |
| 36 | # writes their contents over that of settings.yaml, which is then updated to |
| 37 | # the merged data values. |
| 38 | # This doesn't correctly handle globs in ".override.yml" entries in SRC_URI. |
| 39 | python do_merge_settings () { |
| 40 | import subprocess |
| 41 | |
| 42 | # TODO: Perform the merge in a temporary directory? |
| 43 | workdir = d.getVar('WORKDIR', True) |
| 44 | nativedir = d.getVar('STAGING_DIR_NATIVE', True) |
| 45 | settingsdir = d.getVar('settings_datadir', True) |
| 46 | settingsdir = settingsdir[1:] |
| 47 | settingsdir = os.path.join(nativedir, settingsdir) |
| 48 | cmd = [] |
| 49 | cmd.append(os.path.join(workdir, 'merge_settings.py')) |
| 50 | cmd.append(os.path.join(settingsdir, 'defaults.yaml')) |
Gunnar Mills | 12d2da2 | 2017-10-04 15:38:33 -0500 | [diff] [blame] | 51 | # Used for any settings from the MRW |
Brad Bishop | 7a17b6b | 2018-03-08 22:29:25 -0500 | [diff] [blame] | 52 | use_mrw = df_enabled(d, 'obmc-mrw', 'true') |
Gunnar Mills | 12d2da2 | 2017-10-04 15:38:33 -0500 | [diff] [blame] | 53 | if (use_mrw == 'true'): |
| 54 | cmd.append(os.path.join(settingsdir, 'mrw-settings.override.yaml')) |
Deepak Kodihalli | 51b3d16 | 2017-07-23 14:08:56 -0500 | [diff] [blame] | 55 | |
| 56 | fetch = bb.fetch2.Fetch([], d) |
Kun Yi | e6bd58c | 2017-10-09 23:17:08 -0700 | [diff] [blame] | 57 | override_urls = [url for url in fetch.urls if url.endswith('.override.yml')] |
Deepak Kodihalli | 51b3d16 | 2017-07-23 14:08:56 -0500 | [diff] [blame] | 58 | for url in override_urls: |
| 59 | bb.debug(2, 'Overriding with source: ' + url) |
| 60 | local_base = os.path.basename(fetch.localpath(url)) |
| 61 | filename = os.path.join(workdir, local_base) |
| 62 | cmd.append(filename) |
| 63 | |
| 64 | # Invoke the script and don't catch any resulting exception. |
| 65 | subprocess.check_call(cmd) |
| 66 | } |
| 67 | # python-pyyaml-native is installed by do_configure, so put this task after |
| 68 | addtask merge_settings after do_configure before do_compile |