Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML" |
| 3 | PR = "r1" |
Patrick Venture | 8ded78f | 2018-10-01 20:51:32 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 5 | S = "${WORKDIR}/git" |
Patrick Venture | 1a3fdfa | 2018-11-03 09:42:19 -0700 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 10 | inherit python3native |
Marri Devender Rao | e341401 | 2017-05-29 01:33:26 -0500 | [diff] [blame] | 11 | inherit phosphor-dbus-yaml |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 14 | DEPENDS += "${PYTHON_PN}-sdbus++-native" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 15 | |
Brad Bishop | 10862f2 | 2020-03-25 15:02:29 -0400 | [diff] [blame] | 16 | SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces" |
Andrew Geissler | fe8ee21 | 2020-05-18 17:41:04 +0000 | [diff] [blame] | 17 | SRCREV = "fdd88281dd243b3b9e6140b3f7b59aaaa188f37e" |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 18 | |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 19 | PACKAGECONFIG ??= "libphosphor_dbus" |
Brad Bishop | 82f51bf | 2017-02-13 14:28:28 -0500 | [diff] [blame] | 20 | PACKAGECONFIG[libphosphor_dbus] = " \ |
| 21 | --enable-libphosphor_dbus, \ |
| 22 | --disable-libphosphor_dbus, \ |
| 23 | systemd sdbusplus, \ |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 24 | libsystemd \ |
Brad Bishop | 82f51bf | 2017-02-13 14:28:28 -0500 | [diff] [blame] | 25 | " |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 26 | |
| 27 | PACKAGECONFIG_remove_class-native = "libphosphor_dbus" |
| 28 | PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus" |
| 29 | |
| 30 | BBCLASSEXTEND += "native nativesdk" |