blob: 8c2ae85633f1b3951eabbae7ee26bdc5bf0675ce [file] [log] [blame]
Sergey Solomin89eaea22016-08-16 14:18:18 -05001FILES_${PN}-catalog-extralocales = \
2 "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
3PACKAGES =+ "${PN}-catalog-extralocales"
Jayanth Othayoth1ac52c82017-07-21 04:23:04 -05004PACKAGECONFIG_append = " networkd coredump"
Sergey Solomin89eaea22016-08-16 14:18:18 -05005PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
6 quotacheck kdbus ima smack polkit logind bootchart utmp"
Brad Bishopd4716b52015-10-30 03:02:05 -04007FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
8SRC_URI += "file://default.network"
Andrew Jeffery18598ae2016-11-21 14:37:05 +10309SRC_URI += "file://shutdown-watchdog.conf"
Brad Bishopc8442242016-08-15 20:16:55 -040010SRC_URI += "file://0001-Export-message_append_cmdline.patch"
Edward A. James7875c7e2016-10-14 16:07:14 -050011SRC_URI += "file://0002-systemd-Make-pam-compile-shared-library.patch"
Brad Bishop5083ec32017-01-11 20:42:58 -050012SRC_URI += "file://0003-basic-Factor-out-string-checking-from-name_to_prefix.patch"
13SRC_URI += "file://0004-basic-Use-path-escaping-when-mangling-path-instances.patch"
Ratan Guptabd3edb72017-07-20 12:08:11 +053014#TODO upstream the below patch via below issue
15#https://github.com/openbmc/openbmc/issues/2016
16SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.patch"
Adriana Kobylakc97b08b2017-06-04 15:41:59 -050017SRC_URI += "file://0006-journal-Create-journald-dbus-object.patch"
18SRC_URI += "file://0007-journal-Add-Synchronize-dbus-method.patch"
Brad Bishopd4716b52015-10-30 03:02:05 -040019
Brad Bishope94b9152016-08-08 20:21:44 -040020RRECOMMENDS_${PN} += "obmc-targets"
Brad Bishopd4716b52015-10-30 03:02:05 -040021FILES_${PN} += "${libdir}/systemd/network/default.network"
Andrew Jeffery18598ae2016-11-21 14:37:05 +103022FILES_${PN} += "${libdir}/systemd/system.conf.d/shutdown-watchdog.conf"
Brad Bishopd4716b52015-10-30 03:02:05 -040023
Edward A. James561f6252016-08-04 16:19:18 -050024EXTRA_OECONF += " --disable-hwdb"
25
Brad Bishopd4716b52015-10-30 03:02:05 -040026do_install_append() {
27 install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
Andrew Jeffery18598ae2016-11-21 14:37:05 +103028 install -m 644 -D ${WORKDIR}/shutdown-watchdog.conf ${D}${libdir}/systemd/system.conf.d/shutdown-watchdog.conf
Adriana Kobylakabd70962016-01-30 11:12:10 -060029
30 #TODO Remove after this issue is resolved
31 #https://github.com/openbmc/openbmc/issues/152
32 ln -s /dev/null ${D}/etc/systemd/system/systemd-hwdb-update.service
Brad Bishopd4716b52015-10-30 03:02:05 -040033}