blob: 7c315a8c481a7f8292823e5e4c384c899981db17 [file] [log] [blame]
Chris Austen213cd2a2015-10-24 19:34:11 -05001SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
2DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
3HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
4PR = "r1"
5
Brad Bishopa7156812016-09-06 22:02:03 -04006RRECOMMENDS_${PN} = "virtual-obmc-host-ipmi-hw"
Chris Austen213cd2a2015-10-24 19:34:11 -05007
8inherit obmc-phosphor-license
9
10DEPENDS += "systemd \
Brad Bishop1b8e41a2016-09-08 17:06:59 -040011 host-ipmid \
12 "
Chris Austen254cb562016-01-23 18:00:11 -060013TARGET_CFLAGS += "-fpic"
Chris Austen213cd2a2015-10-24 19:34:11 -050014
15
16RDEPENDS_${PN} += "libsystemd"
17
18
19
20SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
21
Patrick Williams10d86c02016-08-30 11:50:03 -050022SRCREV = "e74fc6bb9221663b1875332944b2f383e39d9a12"
Chris Austen213cd2a2015-10-24 19:34:11 -050023
24FILES_${PN} += "${libdir}/host-ipmid/*.so"
25FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
26
27S = "${WORKDIR}/git"
28
Brad Bishop1b8e41a2016-09-08 17:06:59 -040029do_install() {
Chris Austen213cd2a2015-10-24 19:34:11 -050030 install -m 0755 -d ${D}${libdir}/host-ipmid
31 install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
32}