blob: 5c1a4b4c0bb1a1a7d94b038d285feb2e07bbcbb5 [file] [log] [blame]
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06001SUMMARY = "FRU properties config for ipmi-fru-parser"
2PR = "r1"
Patrick Ventureca2e8962018-11-04 08:14:29 -08003LICENSE = "Apache-2.0"
Brad Bishopa1cee092019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06005
6inherit native
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06007inherit phosphor-ipmi-fru
Matt Spinler3f6fcbe2017-12-14 13:31:55 -06008inherit mrw-xml
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06009
10SRC_URI += "file://config.yaml"
11
12DEPENDS += " \
13 mrw-native \
14 mrw-perl-tools-native \
15 "
16
17PROVIDES += "virtual/phosphor-ipmi-fru-properties"
18
19S = "${WORKDIR}"
20
21do_install() {
22 DEST=${D}${properties_datadir}
23 install -d ${DEST}
24
25 ${bindir}/perl-native/perl \
26 ${bindir}/gen_fru_properties.pl \
Matt Spinler3f6fcbe2017-12-14 13:31:55 -060027 -m ${mrw_datadir}/${MRW_XML} \
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060028 -c config.yaml \
Ratan Guptadccf5ad2017-03-30 14:32:02 +053029 -o ${DEST}/extra-properties.yaml
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060030}