blob: 43572961e4bfc551bceb2869fc5927f1a8b332c2 [file] [log] [blame]
Patrick Williamsf6f2edb2017-01-30 11:05:56 -06001SUMMARY = "Phosphor DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
10
11DEPENDS += "autoconf-archive-native"
Brad Bishop5f7b1712017-02-02 20:49:22 -050012DEPENDS += "sdbus++-native"
Patrick Williamsf6f2edb2017-01-30 11:05:56 -060013
Brad Bishop5f7b1712017-02-02 20:49:22 -050014PACKAGE_BEFORE_PN = "${PN}-yaml"
15
16FILES_${PN}-yaml = "${datadir}/${PN}/yaml"
Patrick Williamsf6f2edb2017-01-30 11:05:56 -060017
18SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
Patrick Williams7e1db462017-03-13 16:40:03 -050019SRCREV = "45a98720d49cdd7b02ddc46d05b29d3e7a9299fe"
Brad Bishop5f7b1712017-02-02 20:49:22 -050020
21DEPENDS_remove_class-native = "sdbus++-native"
22DEPENDS_remove_class-nativesdk = "sdbus++-native"
23
24PACKAGECONFIG ??= "libphosphor_dbus"
Brad Bishop82f51bf2017-02-13 14:28:28 -050025PACKAGECONFIG[libphosphor_dbus] = " \
26 --enable-libphosphor_dbus, \
27 --disable-libphosphor_dbus, \
28 systemd sdbusplus, \
29 libsystemd sdbusplus \
30 "
Brad Bishop5f7b1712017-02-02 20:49:22 -050031
32PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
33PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
34
35BBCLASSEXTEND += "native nativesdk"