Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBUS Object Manager" |
| 2 | DESCRIPTION = "Phosphor DBUS object manager." |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
| 7 | |
Matthew Barth | e997291 | 2016-10-05 16:20:54 -0500 | [diff] [blame] | 8 | inherit autotools pkgconfig |
Matthew Barth | 67cb5a5 | 2016-11-16 10:17:02 -0600 | [diff] [blame] | 9 | inherit obmc-phosphor-python-autotools |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 10 | inherit obmc-phosphor-dbus-service |
| 11 | inherit obmc-phosphor-systemd |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 12 | |
Brad Bishop | 48b1961 | 2016-08-07 23:18:32 -0400 | [diff] [blame] | 13 | DEPENDS += "systemd" |
Matthew Barth | e997291 | 2016-10-05 16:20:54 -0500 | [diff] [blame] | 14 | DEPENDS += "autoconf-archive-native" |
Rick Altherr | c38aae0 | 2016-08-01 14:20:50 -0700 | [diff] [blame] | 15 | |
Brad Bishop | 7476cd1 | 2016-11-02 15:21:22 -0400 | [diff] [blame] | 16 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.ObjectMapper.service" |
Brad Bishop | 231230b | 2016-08-08 20:04:29 -0400 | [diff] [blame] | 17 | SYSTEMD_SERVICE_${PN} = "mapper-wait@.service" |
Matthew Barth | e997291 | 2016-10-05 16:20:54 -0500 | [diff] [blame] | 18 | RDEPENDS_libmapper += "libsystemd" |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 19 | RDEPENDS_${PN} += " \ |
| 20 | python-xml \ |
| 21 | python-dbus \ |
| 22 | python-pygobject \ |
| 23 | " |
Chris Austen | 350def1 | 2015-12-02 22:32:06 -0600 | [diff] [blame] | 24 | SRC_URI += "git://github.com/openbmc/phosphor-objmgr" |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 25 | |
Patrick Williams | 0cb874c | 2017-01-30 13:30:03 -0600 | [diff] [blame] | 26 | SRCREV = "3c18b9f186d0894df83f34021553f72a9d9f0a8b" |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 27 | |
| 28 | S = "${WORKDIR}/git" |
Brad Bishop | 9a701b4 | 2016-07-26 15:52:01 -0400 | [diff] [blame] | 29 | |
Brad Bishop | 9a701b4 | 2016-07-26 15:52:01 -0400 | [diff] [blame] | 30 | python populate_packages_prepend () { |
| 31 | mapperlibdir = d.getVar("libdir", True) |
| 32 | do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True) |
| 33 | } |
| 34 | PACKAGES_DYNAMIC += "^libmapper.*" |
| 35 | FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*" |