blob: 452faa3e5be0dfb417b6efc47859c6114e9e410f [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC inventory manager"
2DESCRIPTION = "OpenBMC inventory manager."
3PR = "r1"
4
5inherit skeleton-python
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-dbus-service
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
Matt Spinler6f5fba12016-09-13 16:20:01 -05008RRECOMMENDS_${PN} += "virtual-obmc-inventory-data"
Brad Bishop86ee1cf2016-06-27 14:53:52 -04009
Andrew Geissler35d42682018-01-02 14:54:19 -060010VIRTUAL-RUNTIME_skeleton_workbook ?= ""
11
Brad Bishop86ee1cf2016-06-27 14:53:52 -040012RDEPENDS_${PN} += "\
Adriana Kobylakca2b6a92016-08-26 09:39:39 -050013 python-argparse \
Brad Bishop86ee1cf2016-06-27 14:53:52 -040014 python-dbus \
15 python-json \
16 python-pickle \
17 python-pygobject \
Adriana Kobylakca2b6a92016-08-26 09:39:39 -050018 python-subprocess \
Brad Bishop1b4e4472016-08-29 21:47:04 -040019 pyphosphor-dbus \
Brad Bishop86ee1cf2016-06-27 14:53:52 -040020 ${VIRTUAL-RUNTIME_skeleton_workbook} \
21 "
22
23SKELETON_DIR = "pyinventorymgr"
Brad Bishop0fe80462016-08-17 20:27:37 -040024DBUS_SERVICE_${PN} += "org.openbmc.Inventory.service"
25SYSTEMD_SERVICE_${PN} += "obmc-sync-inventory-item@.service"