blob: ab2c38e90ee912bd90c3b7df37e0b16a2703b2b4 [file] [log] [blame]
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06001SUMMARY = "Phosphor OpenBMC pre-init scripts"
Gunnar Mills38f27112018-08-31 12:39:15 -05002DESCRIPTION = "Phosphor OpenBMC filesystem mount reference implementation."
Brad Bishopab2908b2018-06-19 15:21:01 -04003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06005
Brad Bishopab2908b2018-06-19 15:21:01 -04006PR = "r1"
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06007
Brad Bishop0aa85942018-07-23 15:25:34 -04008inherit allarch
9
Brad Bishopaa3349c2018-06-19 15:24:49 -040010RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_base-utils}"
11
Milton D. Miller IId89d5e02016-01-20 14:57:54 -060012S = "${WORKDIR}"
13SRC_URI += "file://obmc-init.sh"
14SRC_URI += "file://obmc-shutdown.sh"
15SRC_URI += "file://obmc-update.sh"
16SRC_URI += "file://whitelist"
17
18do_install() {
Milton D. Miller IIb1136c02016-03-07 14:42:50 -060019 for f in init-download-url init-options
20 do
21 if test -e $f
22 then
23 install -m 0755 ${WORKDIR}/$f ${D}/$f
24 fi
25 done
Milton D. Miller IId89d5e02016-01-20 14:57:54 -060026 install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
27 install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
28 install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
29 install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
30 install -d ${D}/dev
31 mknod -m 622 ${D}/dev/console c 5 1
32}
33
34FILES_${PN} += " /init /shutdown /update /whitelist /dev "
Milton D. Miller IIb1136c02016-03-07 14:42:50 -060035FILES_${PN} += " /init-options /init-download-url "