Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBUS to REST WSGI Application" |
| 2 | DESCRIPTION = "Phosphor DBUS to REST WSGI Application." |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-rest-server" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 7 | |
| 8 | inherit allarch |
| 9 | inherit obmc-phosphor-systemd |
| 10 | inherit setuptools |
Ratan Gupta | 653779c | 2016-10-01 14:57:15 -0500 | [diff] [blame] | 11 | inherit obmc-phosphor-discovery-service |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 12 | |
Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 13 | RRECOMMENDS_${PN} += "virtual-obmc-wsgihost" |
| 14 | |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 15 | RDEPENDS_${PN} += " \ |
| 16 | python-xml \ |
| 17 | python-dbus \ |
Brad Bishop | 1122eb0 | 2016-10-05 20:10:23 -0400 | [diff] [blame] | 18 | phosphor-mapper \ |
Brad Bishop | f668817 | 2016-04-15 09:41:54 -0400 | [diff] [blame] | 19 | python-bottle \ |
| 20 | python-spwd \ |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 21 | pyphosphor-utils \ |
| 22 | pyphosphor-dbus \ |
Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 23 | pyphosphor-wsgi-apps-ns \ |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 24 | " |
Chris Austen | 350def1 | 2015-12-02 22:32:06 -0600 | [diff] [blame] | 25 | SRC_URI += "git://github.com/openbmc/phosphor-rest-server" |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 26 | |
Patrick Williams | a8bbcb0 | 2016-09-12 13:50:05 -0500 | [diff] [blame] | 27 | SRCREV = "dc3fbfa7d1861a4bb65fb284228a6ea155ba37a5" |
Brad Bishop | 5da8564 | 2015-10-27 17:13:26 -0400 | [diff] [blame] | 28 | |
Brad Bishop | 0a81db0 | 2016-08-30 00:46:40 -0400 | [diff] [blame] | 29 | S = "${WORKDIR}/git/module" |
| 30 | SYSTEMD_SERVICE_${PN} = "" |
| 31 | SYSTEMD_OVERRIDE_${PN} += "rest-dbus.conf:obmc-mapper.target.d/rest-dbus.conf" |
| 32 | SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/wsgi_app" |
Ratan Gupta | 653779c | 2016-10-01 14:57:15 -0500 | [diff] [blame] | 33 | REGISTERED_SERVICES_${PN} += "phosphor_rest:tcp:443" |