Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML" |
| 3 | PR = "r1" |
Patrick Venture | 8ded78f | 2018-10-01 20:51:32 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 5 | S = "${WORKDIR}/git" |
Patrick Venture | 1a3fdfa | 2018-11-03 09:42:19 -0700 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 8 | |
Patrick Williams | 7e63969 | 2020-09-08 16:51:14 -0500 | [diff] [blame] | 9 | inherit meson |
| 10 | inherit obmc-phosphor-utils |
Marri Devender Rao | e341401 | 2017-05-29 01:33:26 -0500 | [diff] [blame] | 11 | inherit phosphor-dbus-yaml |
Patrick Williams | 7e63969 | 2020-09-08 16:51:14 -0500 | [diff] [blame] | 12 | inherit python3native |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 13 | |
Patrick Williams | 4da53be | 2020-09-08 15:33:11 -0500 | [diff] [blame] | 14 | DEPENDS += " \ |
| 15 | ${PYTHON_PN}-sdbus++-native \ |
Patrick Williams | 4da53be | 2020-09-08 15:33:11 -0500 | [diff] [blame] | 16 | sdbusplus \ |
| 17 | systemd \ |
| 18 | " |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 19 | |
Brad Bishop | 10862f2 | 2020-03-25 15:02:29 -0400 | [diff] [blame] | 20 | SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces" |
Andrew Geissler | 6946d4c | 2020-12-22 16:52:36 +0000 | [diff] [blame] | 21 | SRCREV = "4c7663b0e50e13724efe62284073eca6ac2fcb24" |
Patrick Williams | 7e63969 | 2020-09-08 16:51:14 -0500 | [diff] [blame] | 22 | |
| 23 | # Process OBMC_ORG_YAML_SUBDIRS to create Meson config options. |
| 24 | # ex. xyz/openbmc_project -> -Ddata_xyz_openbmc_project=true |
| 25 | def pdi_meson_config(d): |
| 26 | return ' '.join([ |
| 27 | '-Ddata_' + x.replace('/', '_') + '=true' \ |
| 28 | for x in listvar_to_list(d, 'OBMC_ORG_YAML_SUBDIRS') |
| 29 | ]) |
Patrick Williams | f48f5ba | 2020-09-15 10:33:02 -0500 | [diff] [blame] | 30 | pdi_meson_config[vardeps] = "OBMC_ORG_YAML_SUBDIRS" |
Patrick Williams | 7e63969 | 2020-09-08 16:51:14 -0500 | [diff] [blame] | 31 | |
Patrick Williams | 6a07a16 | 2020-10-06 11:43:40 -0500 | [diff] [blame] | 32 | # Markdown files are installed into /usr/share/phosphor-dbus-interfaces so |
| 33 | # add them to the 'doc' subpackage. |
| 34 | FILES_${PN}-doc += "${datadir}/${BPN}" |
| 35 | |
| 36 | EXTRA_OEMESON_append = " \ |
| 37 | -Db_lto=true \ |
| 38 | ${@pdi_meson_config(d)}" |