blob: 399aa017c643299fd96db9faf504942187ce375c [file] [log] [blame]
Brad Bishop595edcf2016-11-09 20:43:11 -05001SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
3HOMEPAGE = "http://github.com/openbmc/sdbusplus"
4PR = "r1"
Patrick Venture66d15842018-10-17 07:19:55 -07005PV = "1.0+git${SRCPV}"
Brad Bishop595edcf2016-11-09 20:43:11 -05006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit autotools pkgconfig
Patrick Williams58185302016-11-22 07:01:14 -060010inherit obmc-phosphor-python-autotools
Brad Bishop595edcf2016-11-09 20:43:11 -050011
Nagaraju Goruganti78077a52017-08-22 05:24:26 -050012DEPENDS += " \
13 autoconf-archive-native \
14 python-inflection-native \
15 python-mako-native \
16 python-pyyaml-native \
17 "
Brad Bishop29dc8702017-01-12 14:06:43 -050018RDEPENDS_sdbus++ += " \
Brad Bishop595edcf2016-11-09 20:43:11 -050019 python-inflection \
20 python-mako \
21 python-pyyaml \
22 "
23
Brad Bishop32f0a9a2017-01-18 13:59:33 -050024# sdbus++ has a handful of runtime dependencies on other python packages.
25# Bitbake doesn't do anything with RDEPENDS in native context because
26# native context doesn't have packages.
27#
28# While technically sdbus++ doesn't require its runtime dependencies to be
29# installed to build, work around the above native context behavior
30# by adding a build dependency so that clients don't have to DEPEND
31# on sdbus++ runtime dependencies manually.
32
33DEPENDS_append_class-native = " \
34 python-inflection-native \
35 python-mako-native \
36 python-pyyaml-native \
37 "
38
Brad Bishop595edcf2016-11-09 20:43:11 -050039SRC_URI += "git://github.com/openbmc/sdbusplus"
Andrew Geissler49a5c2a2019-05-17 16:01:55 +000040SRCREV = "c077190dfa34f83869685a34fce78d57bfc96f76"
Brad Bishop595edcf2016-11-09 20:43:11 -050041
Adriana Kobylak178d6b52017-02-12 17:40:26 -060042PACKAGECONFIG ??= "libsdbusplus transaction"
Brad Bishop595edcf2016-11-09 20:43:11 -050043PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
Adriana Kobylak178d6b52017-02-12 17:40:26 -060044PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
Brad Bishop595edcf2016-11-09 20:43:11 -050045
46S = "${WORKDIR}/git"
47
Patrick Williams29792022016-11-22 11:05:11 -060048PROVIDES_prepend = "sdbus++ "
Brad Bishopcc01d1a2018-02-27 00:30:06 -050049PACKAGE_BEFORE_PN = "sdbus++"
Patrick Williams29792022016-11-22 11:05:11 -060050FILES_sdbus++_append = " ${bindir}/sdbus++"
51PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
52
Brad Bishop595edcf2016-11-09 20:43:11 -050053PACKAGECONFIG_remove_class-native = "libsdbusplus"
54PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
55
Brad Bishop595edcf2016-11-09 20:43:11 -050056BBCLASSEXTEND += "native nativesdk"