blob: da4fb128c384b6a01e983bc2daf3feb13202e45e [file] [log] [blame]
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +05301SUMMARY = "Phosphor User Manager Daemon"
2DESCRIPTION = "Daemon that does user management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-user-manager"
4PR = "r1"
Patrick Venture01b443e2018-10-02 20:51:15 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venture01b443e2018-10-02 20:51:15 -07008
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +05309inherit autotools pkgconfig
10inherit obmc-phosphor-dbus-service
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbusplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "phosphor-dbus-interfaces"
Tom Joseph1c1845e2018-07-10 12:23:06 -050016DEPENDS += "boost"
Andrew Geisslere1610d72018-10-09 04:10:28 +000017DEPENDS += "nss-pam-ldapd"
Brad Bishop26873c92019-03-22 23:41:42 -040018DEPENDS += "systemd"
Nagaraju Goruganti6d7f6402018-09-03 21:56:42 -050019PACKAGE_BEFORE_PN = "phosphor-ldap"
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053020
Richard Marian Thomaiyar0aed5da2018-04-12 16:06:36 -070021inherit useradd
22
Nagaraju Goruganti6d7f6402018-09-03 21:56:42 -050023USERADD_PACKAGES = "${PN} phosphor-ldap"
24DBUS_PACKAGES = "${USERADD_PACKAGES}"
Richard Marian Thomaiyar0aed5da2018-04-12 16:06:36 -070025# add groups needed for privilege maintenance
Richard Marian Thomaiyar96e5ce12019-11-08 17:26:00 +053026GROUPADD_PARAM_${PN} = "priv-admin; priv-operator; priv-user "
27GROUPADD_PARAM_phosphor-ldap = "priv-admin; priv-operator; priv-user "
Richard Marian Thomaiyar41882fb2018-12-14 09:04:40 +053028
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053029DBUS_SERVICE_${PN} += "xyz.openbmc_project.User.Manager.service"
Nagaraju Goruganti6d7f6402018-09-03 21:56:42 -050030FILES_phosphor-ldap += " \
Patrick Venture7c9d6f92019-04-04 10:03:09 -070031 ${bindir}/phosphor-ldap-conf \
32 ${bindir}/phosphor-ldap-mapper \
Nagaraju Goruganti6d7f6402018-09-03 21:56:42 -050033"
Tom Joseph70474372018-10-07 05:51:04 -050034DBUS_SERVICE_phosphor-ldap = " \
35 xyz.openbmc_project.Ldap.Config.service \
36 xyz.openbmc_project.LDAP.PrivilegeMapper.service \
37"
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053038SRC_URI += "git://github.com/openbmc/phosphor-user-manager"
Andrew Geisslere3986212020-10-04 07:11:38 +000039SRCREV = "75be4e68c7a599650a1800d7846182b06534bdca"
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053040S = "${WORKDIR}/git"