Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 1 | HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash" |
| 2 | SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB" |
| 3 | DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol." |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "phosphor-ipmi-blobs" |
| 14 | DEPENDS += "phosphor-logging" |
| 15 | DEPENDS += "sdbusplus" |
Patrick Venture | f0bb2a9 | 2019-03-07 10:51:53 -0800 | [diff] [blame] | 16 | DEPENDS += "ipmi-blob-tool" |
Patrick Venture | cb35b59 | 2019-05-03 10:35:28 -0700 | [diff] [blame] | 17 | DEPENDS += "pciutils" |
Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 18 | |
Patrick Venture | f65a4e2 | 2019-05-15 12:19:16 -0700 | [diff] [blame] | 19 | EXTRA_OECONF = "--disable-tests --disable-build-host-tool" |
| 20 | |
Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 21 | S = "${WORKDIR}/git" |
| 22 | SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash" |
Andrew Geissler | 1c388d3 | 2019-05-17 21:32:15 +0000 | [diff] [blame] | 23 | SRCREV = "3ecb3503d851d173bcb11cd190813dd1ad2e2d67" |
Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 24 | |
| 25 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 26 | FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}" |
| 27 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 28 | |
| 29 | BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so" |
Patrick Venture | e21be19 | 2019-05-08 07:43:10 -0700 | [diff] [blame] | 30 | |
| 31 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |