blob: 2a0aab673b12b3ee7317e3ebee77bcdab557ca5f [file] [log] [blame]
Tom Josephf2614f92017-05-08 11:49:10 +05301SUMMARY = "Inventory to Sensor config for non-mrw machines"
2PR = "r1"
Patrick Venturea34f1942018-11-03 16:36:18 -07003LICENSE = "Apache-2.0"
Brad Bishopa1cee092019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Tom Josephf2614f92017-05-08 11:49:10 +05305
6inherit native
7inherit phosphor-ipmi-host
Tom Josephf2614f92017-05-08 11:49:10 +05308
9PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
10
11SRC_URI += "file://config.yaml"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # This recipe would provide the sample inventory to sensor config
17 # mapping, for non-mrw machines.
18
19 DEST=${D}${sensor_datadir}
20 install -d ${DEST}
21 install config.yaml ${DEST}/invsensor.yaml
22}