Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 1 | HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash" |
| 2 | SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB" |
| 3 | DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol." |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "phosphor-ipmi-blobs" |
| 14 | DEPENDS += "phosphor-logging" |
| 15 | DEPENDS += "sdbusplus" |
Patrick Venture | f0bb2a9 | 2019-03-07 10:51:53 -0800 | [diff] [blame] | 16 | DEPENDS += "ipmi-blob-tool" |
Patrick Venture | cb35b59 | 2019-05-03 10:35:28 -0700 | [diff] [blame] | 17 | DEPENDS += "pciutils" |
Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 18 | |
Andrew Geissler | 67a224f | 2019-06-19 18:52:19 +0000 | [diff] [blame] | 19 | PACKAGECONFIG ?= "cleanup-delete" |
| 20 | PACKAGECONFIG[cleanup-delete] = "--enable-cleanup-delete, --disable-cleanup-delete" |
| 21 | |
Patrick Venture | f65a4e2 | 2019-05-15 12:19:16 -0700 | [diff] [blame] | 22 | EXTRA_OECONF = "--disable-tests --disable-build-host-tool" |
| 23 | |
Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 24 | S = "${WORKDIR}/git" |
| 25 | SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash" |
Andrew Geissler | 58b5bef | 2019-06-20 20:02:20 +0000 | [diff] [blame^] | 26 | SRCREV = "03db87e481fc09f3e5ab84e8207f72a11d3ab1ea" |
Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 27 | |
| 28 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 29 | FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}" |
| 30 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 31 | |
| 32 | BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so" |
Andrew Geissler | 67a224f | 2019-06-19 18:52:19 +0000 | [diff] [blame] | 33 | BLOBIPMI_PROVIDER_LIBRARY += "${@bb.utils.contains('PACKAGECONFIG', 'cleanup-delete', 'libfirmwarecleanupblob.so', '', d)}" |
Patrick Venture | e21be19 | 2019-05-08 07:43:10 -0700 | [diff] [blame] | 34 | |
| 35 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |