James Feist | e8c0ec9 | 2018-10-02 16:45:42 -0700 | [diff] [blame] | 1 | SUMMARY = "Entity Manager" |
| 2 | DESCRIPTION = "Entity Manager provides d-bus configuration data \ |
| 3 | and configures system sensors" |
| 4 | |
Brad Bishop | c497f35 | 2020-08-18 19:06:53 -0400 | [diff] [blame] | 5 | SRC_URI = "git://github.com/openbmc/entity-manager.git file://blocklist.json" |
Andrew Geissler | 472c23f | 2021-01-12 16:51:14 +0000 | [diff] [blame] | 6 | SRCREV = "10a8c5fe933e82214538f43947a185a66cfa04f0" |
James Feist | e8c0ec9 | 2018-10-02 16:45:42 -0700 | [diff] [blame] | 7 | PV = "0.1+git${SRCPV}" |
| 8 | |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b" |
| 11 | |
James Feist | e8c0ec9 | 2018-10-02 16:45:42 -0700 | [diff] [blame] | 12 | DEPENDS = "boost \ |
Brad Bishop | 2a141b6 | 2020-11-06 09:39:44 -0500 | [diff] [blame] | 13 | dbus \ |
James Feist | e8c0ec9 | 2018-10-02 16:45:42 -0700 | [diff] [blame] | 14 | nlohmann-json \ |
| 15 | sdbusplus \ |
| 16 | valijson" |
| 17 | |
Brad Bishop | 29d26b3 | 2020-10-27 09:22:51 -0400 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
Brad Bishop | c970890 | 2020-02-14 14:07:11 -0500 | [diff] [blame] | 19 | inherit meson systemd |
Brad Bishop | 6281b85 | 2020-03-18 16:33:02 -0400 | [diff] [blame] | 20 | |
Brad Bishop | 97d49ab | 2020-03-30 14:16:34 -0400 | [diff] [blame] | 21 | EXTRA_OEMESON = "-Dtests=disabled" |
| 22 | |
Brad Bishop | 4525a9d | 2020-08-18 19:30:11 -0400 | [diff] [blame] | 23 | PACKAGECONFIG ??= "ipmi-fru" |
Brad Bishop | 6281b85 | 2020-03-18 16:33:02 -0400 | [diff] [blame] | 24 | PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools," |
Brad Bishop | c497f35 | 2020-08-18 19:06:53 -0400 | [diff] [blame] | 25 | |
Brad Bishop | 4525a9d | 2020-08-18 19:30:11 -0400 | [diff] [blame] | 26 | EXTRA_ENTITY_MANAGER_PACKAGES = " \ |
| 27 | ${@bb.utils.contains('PACKAGECONFIG', 'ipmi-fru', 'fru-device', '', d)} \ |
| 28 | " |
| 29 | |
| 30 | PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}" |
| 31 | |
Brad Bishop | c497f35 | 2020-08-18 19:06:53 -0400 | [diff] [blame] | 32 | do_install_append() { |
| 33 | install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json |
| 34 | } |
Brad Bishop | 4525a9d | 2020-08-18 19:30:11 -0400 | [diff] [blame] | 35 | |
Brad Bishop | 2a141b6 | 2020-11-06 09:39:44 -0500 | [diff] [blame] | 36 | FILES_${PN} += " \ |
| 37 | ${datadir}/dbus-1/system-services/xyz.openbmc_project.EntityManager.service \ |
| 38 | " |
Brad Bishop | 4525a9d | 2020-08-18 19:30:11 -0400 | [diff] [blame] | 39 | FILES_fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json" |
| 40 | |
| 41 | SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}" |
| 42 | SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service" |
| 43 | SYSTEMD_SERVICE_fru-device = "xyz.openbmc_project.FruDevice.service" |
| 44 | SYSTEMD_AUTO_ENABLE_fru-device_ibm-power-cpu = "disable" |