blob: 2502065eb95505257d069ed432a5acc65c91f40f [file] [log] [blame]
vishwabmc1bf499d2015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc1bf499d2015-10-09 15:51:50 +05303PR = "r1"
Patrick Venturef30b8842018-10-21 08:27:22 -07004PV = "1.0+git${SRCPV}"
Patrick Venture64329372018-11-03 09:42:59 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
vishwabmc1bf499d2015-10-09 15:51:50 +05307
Brad Bishop7ee71462016-08-19 09:02:54 -05008RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen213cd2a2015-10-24 19:34:11 -05009
Matthew Barth302592f2016-08-16 16:51:35 -050010inherit autotools pkgconfig
Patrick Ventured3dd0942017-12-22 14:36:07 -080011inherit obmc-phosphor-ipmiprovider-symlink
Patrick Williamsf7714062015-10-15 15:20:20 -050012inherit obmc-phosphor-sdbus-service
Patrick Ventured3dd0942017-12-22 14:36:07 -080013inherit obmc-phosphor-systemd
Ratan Guptab92d0ec2017-03-06 17:05:11 +053014inherit phosphor-ipmi-host
15inherit pythonnative
vishwabmc1bf499d2015-10-09 15:51:50 +053016
Brad Bishop7f2ade02018-01-26 22:11:36 -050017def ipmi_whitelists(d):
18 whitelists = d.getVar(
19 'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
20 whitelists = whitelists.split()
21 whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
22 return ' '.join(whitelists)
23
Patrick Ventured3dd0942017-12-22 14:36:07 -080024DEPENDS += "autoconf-archive-native"
David Cobbley1dc78fb2017-11-21 16:17:40 -080025DEPENDS += "nlohmann-json"
Patrick Ventured3dd0942017-12-22 14:36:07 -080026DEPENDS += "obmc-targets"
Brad Bishop7f2ade02018-01-26 22:11:36 -050027DEPENDS += "${@ipmi_whitelists(d)}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080028DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak17885c22017-02-17 08:21:42 -060029DEPENDS += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040030DEPENDS += "phosphor-mapper"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053031DEPENDS += "sdbusplus"
Patrick Ventured3dd0942017-12-22 14:36:07 -080032DEPENDS += "sdbus++-native"
Tom Josephf2614f92017-05-08 11:49:10 +053033DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050034DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
Patrick Ventured3dd0942017-12-22 14:36:07 -080035DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Patrick Ventureafdf9842018-01-18 18:01:29 -080036DEPENDS += "virtual/phosphor-ipmi-channel-config"
Andrew Geisslera561ec92018-09-25 19:50:20 +000037DEPENDS += "boost"
Ratan Guptab92d0ec2017-03-06 17:05:11 +053038
Andrew Jeffery381e1e92018-04-06 14:13:14 +093039VIRTUAL-RUNTIME_ipmi-config ?= "phosphor-ipmi-config"
40
Adriana Kobylak17885c22017-02-17 08:21:42 -060041RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040042RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller II611e3ff2016-03-04 15:29:29 -060043RDEPENDS_${PN} += "clear-once"
Brad Bishop9a701b42016-07-26 15:52:01 -040044RDEPENDS_${PN} += "libmapper"
Patrick Ventured3dd0942017-12-22 14:36:07 -080045RDEPENDS_${PN} += "network"
46RDEPENDS_${PN} += "phosphor-dbus-interfaces"
47RDEPENDS_${PN} += "phosphor-mapper"
Vishwanatha Subbanna78bc5422016-11-10 21:52:46 +053048RDEPENDS_${PN} += "phosphor-time-manager"
Patrick Ventured3dd0942017-12-22 14:36:07 -080049RDEPENDS_${PN} += "sdbusplus"
Andrew Jeffery381e1e92018-04-06 14:13:14 +093050RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_ipmi-config}"
Vishwanatha Subbanna55c545a2017-06-12 13:09:10 +053051RDEPENDS_${PN} += "virtual/obmc-watchdog"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053052
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053053inherit useradd
54
55USERADD_PACKAGES = "${PN}"
56# add ipmi group
57GROUPADD_PARAM_${PN} = "ipmi"
58
Vishwanatha Subbanna35318402017-03-31 14:41:11 +053059SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
60
Andrew Geissler78e04542018-02-05 12:02:35 -080061RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-settings-mgmt}"
62
vishwabmc1bf499d2015-10-09 15:51:50 +053063
Marri Devender Rao52a9f2d2017-06-08 00:47:54 -050064require ${PN}.inc
Chris Austen213cd2a2015-10-24 19:34:11 -050065
Tom Josephf07ae012017-02-20 12:01:43 +053066# Setup IPMI Whitelist Conf files
67WHITELIST_CONF = " \
Patrick Williamsf11f0152017-02-24 13:04:06 -060068 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Josephf07ae012017-02-20 12:01:43 +053069 ${S}/host-ipmid-whitelist.conf \
70 "
71EXTRA_OECONF = " \
72 WHITELIST_CONF="${WHITELIST_CONF}" \
Ratan Guptab92d0ec2017-03-06 17:05:11 +053073 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephf2614f92017-05-08 11:49:10 +053074 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050075 FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
Patrick Ventureafdf9842018-01-18 18:01:29 -080076 CHANNEL_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/channel.yaml \
Marri Devender Rao9f32d172018-01-18 11:21:19 -060077 POWER_READING_SENSOR=${datadir}/ipmi-providers/power_reading.json\
Tom Josephf07ae012017-02-20 12:01:43 +053078 "
79
vishwabmc1bf499d2015-10-09 15:51:50 +053080S = "${WORKDIR}/git"
81
Andrew Jeffery381e1e92018-04-06 14:13:14 +093082SRC_URI += "file://merge_yamls.py "
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -050083
Vernon Mauery595c7382018-07-30 15:49:09 -070084HOSTIPMI_PROVIDER_LIBRARY += "libipmi20.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053085HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
86
Vernon Mauery595c7382018-07-30 15:49:09 -070087NETIPMI_PROVIDER_LIBRARY += "libipmi20.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053088
Matthew Barth302592f2016-08-16 16:51:35 -050089FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080090FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053091FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
92FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop3b524cf2016-09-06 13:03:39 -040093
Andrew Geisslerafc510f2017-01-04 11:11:50 -060094# Soft Power Off
Andrew Geisslerd40db752017-05-11 16:16:27 -050095# install the soft power off service in the host shutdown target
96SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
97SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
98SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
99SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500100
101#Collect all hardcoded sensor yamls from different recipes and
102#merge all of them with sensor.yaml.
103python do_merge_sensors () {
104 import subprocess
105
106 # TODO: Perform the merge in a temporary directory?
107 workdir = d.getVar('WORKDIR', True)
108 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
109 sensorsdir = d.getVar('sensor_datadir', True)
110 sensorsdir = sensorsdir[1:]
111 sensorsdir = os.path.join(nativedir, sensorsdir)
112 cmd = []
113 cmd.append(os.path.join(workdir, 'merge_yamls.py'))
114 cmd.append(os.path.join(sensorsdir, 'sensor.yaml'))
115
116 if os.stat(os.path.join(sensorsdir, 'sensor.yaml')).st_size == 0:
117 return
118 fetch = bb.fetch2.Fetch([], d)
Kun Yie6bd58c2017-10-09 23:17:08 -0700119 override_urls = [url for url in fetch.urls if url.endswith('.hardcoded.yaml')]
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500120 for url in override_urls:
121 bb.debug(2, 'Overriding with source: ' + url)
122 local_base = os.path.basename(fetch.localpath(url))
123 filename = os.path.join(workdir, local_base)
124 cmd.append(filename)
125
126 # Invoke the script and don't catch any resulting exception.
127 subprocess.check_call(cmd)
128}
Andrew Jeffery381e1e92018-04-06 14:13:14 +0930129
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500130# python-pyyaml-native is installed by do_configure, so put this task after
131addtask merge_sensors after do_configure before do_compile