blob: 4363b1e53dd3c03cecc9d38edf3286437b4a1d4b [file] [log] [blame]
Adriana Kobylak2ca101c2016-01-30 08:53:35 -06001SUMMARY = "Settings DBUS object"
2DESCRIPTION = "Settings DBUS object"
3HOMEPAGE = "http://github.com/openbmc/phosphor-settingsd"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8
9RDEPENDS_${PN} += "python-dbus python-pygobject"
10
11SRC_URI += "git://github.com/openbmc/phosphor-settingsd"
12
Patrick Williams636200f2016-09-23 15:20:07 -050013SRCREV = "d5b7e9385bd62dddaf765810c16f68ea2a1c6324"
Adriana Kobylak2ca101c2016-01-30 08:53:35 -060014
15S = "${WORKDIR}/git"
16
17do_install() {
18 install -d ${D}/${sbindir}
19 install ${S}/settings_file.py ${D}/${sbindir}
20 install ${S}/settings_manager.py ${D}/${sbindir}
21}
22