Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor ipmi tool for injecting ipmi commands" |
| 2 | DESCRIPTION = "IPMI Tool with dbus capabilities" |
| 3 | HOMEPAGE = "https://github.com/openbmc/ipmitool" |
| 4 | PR = "r1" |
Patrick Venture | fd7bdbc | 2018-10-05 15:45:41 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Patrick Venture | 6f37e9a | 2018-11-03 13:59:34 -0700 | [diff] [blame] | 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184" |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 8 | |
| 9 | DEPENDS += "systemd \ |
Brad Bishop | c30d7bb | 2017-01-17 10:07:14 -0500 | [diff] [blame] | 10 | phosphor-ipmi-host \ |
Brad Bishop | 1b8e41a | 2016-09-08 17:06:59 -0400 | [diff] [blame] | 11 | " |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 12 | |
Brad Bishop | 1b8e41a | 2016-09-08 17:06:59 -0400 | [diff] [blame] | 13 | RDEPENDS_${PN} += "libsystemd \ |
| 14 | libcrypto \ |
Brad Bishop | a6ec1d5 | 2016-09-08 17:09:18 -0400 | [diff] [blame] | 15 | virtual-obmc-host-ipmi-hw \ |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | |
| 19 | SRC_URI += "git://github.com/openbmc/ipmitool" |
| 20 | |
Vernon Mauery | 757c64b | 2018-07-23 12:05:08 -0700 | [diff] [blame] | 21 | SRCREV = "dfdfd89ec9b36c115a98f589880fd757a162af19" |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 22 | |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | |
| 27 | do_compile() { |
Brad Bishop | 1b8e41a | 2016-09-08 17:06:59 -0400 | [diff] [blame] | 28 | ${S}/bootstrap --enable-intf-dbus |
| 29 | ${S}/configure --host x86_64 |
| 30 | make |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 31 | } |
| 32 | |
Brad Bishop | 1b8e41a | 2016-09-08 17:06:59 -0400 | [diff] [blame] | 33 | do_install() { |
| 34 | install -m 0755 -d ${D}${sbindir} |
| 35 | install -m 0755 ${S}/src/ipmitool ${D}${sbindir} |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 36 | } |