blob: 11cfe344216f12bc3a6ea7d1eb194a3e27f02215 [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
Brad Bishop93fb5352015-09-09 03:59:20 +00005inherit obmc-phosphor-license
6
Brad Bishop93fb5352015-09-09 03:59:20 +00007PROVIDES = "${PACKAGES}"
8PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -05009 ${PN}-bmc-state-mgmt \
10 ${PN}-chassis-state-mgmt \
Brad Bishop6165ec32016-09-06 22:44:21 -040011 ${PN}-extras \
12 ${PN}-extrasdev \
Adriana Kobylak0bce5322017-11-09 10:39:02 -060013 ${PN}-extrasdevtools \
Brad Bishop11909e02017-05-01 11:54:34 -040014 ${PN}-fan-control \
Brad Bishop46631702017-03-01 16:16:06 -050015 ${PN}-host-state-mgmt \
Brad Bishop45f8b572017-02-01 21:04:14 -050016 ${PN}-inventory \
17 ${PN}-leds \
18 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060019 ${PN}-software \
Andrew Geisslera94faf42017-05-08 15:58:01 -050020 ${PN}-host-check-mgmt \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050021 ${PN}-debug-collector \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050022 ${PN}-settings \
Ratan Guptab6de45c2017-07-06 21:09:14 +053023 ${PN}-network \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053024 ${PN}-user-mgmt \
Brad Bishop93fb5352015-09-09 03:59:20 +000025 "
26
Brad Bishop46631702017-03-01 16:16:06 -050027SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
28RDEPENDS_${PN}-bmc-state-mgmt = " \
29 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
30 "
31
32SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
33RDEPENDS_${PN}-chassis-state-mgmt = " \
34 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
35 "
36
Brad Bishop6165ec32016-09-06 22:44:21 -040037SUMMARY_${PN}-extras = "Extra features"
38RDEPENDS_${PN}-extras = " \
Brad Bishop667938f2017-01-12 21:44:51 -050039 phosphor-rest \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040040 phosphor-dbus-monitor \
Brad Bishop70436da2015-09-16 14:49:27 -040041 "
42
Brad Bishop6165ec32016-09-06 22:44:21 -040043SUMMARY_${PN}-extrasdev = "Development features"
44RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylakeaa56c92016-06-16 14:46:06 -050045 rest-dbus \
46 "
Brad Bishop45f8b572017-02-01 21:04:14 -050047
Adriana Kobylak0bce5322017-11-09 10:39:02 -060048SUMMARY_${PN}-extrasdevtools = "Development tools"
49RDEPENDS_${PN}-extrasdevtools = " \
50 "
51
Brad Bishop11909e02017-05-01 11:54:34 -040052# Use the fan control package group for applications
53# implementing fan control or system fan policy only.
54# Applications that create inventory or sensors should
55# be added those respective package groups instead.
56SUMMARY_${PN}-fan-control = "Fan control"
57RDEPENDS_${PN}-fan-control = " \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050058 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinler39652c82017-05-01 14:29:20 -050059 phosphor-fan-monitor \
Brad Bishop11909e02017-05-01 11:54:34 -040060 "
61
Brad Bishop46631702017-03-01 16:16:06 -050062SUMMARY_${PN}-host-state-mgmt = "Host state management"
63RDEPENDS_${PN}-host-state-mgmt = " \
64 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -050065 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -050066 "
67
Brad Bishop45f8b572017-02-01 21:04:14 -050068SUMMARY_${PN}-inventory = "Inventory applications"
69RDEPENDS_${PN}-inventory = " \
70 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -060071 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop45f8b572017-02-01 21:04:14 -050072 "
73
74SUMMARY_${PN}-leds = "LED applications"
75RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -050076 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
77 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandrane1266ad2017-04-27 05:29:56 -050078 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop45f8b572017-02-01 21:04:14 -050079 "
80
81SUMMARY_${PN}-sensors = "Sensor applications"
82RDEPENDS_${PN}-sensors = " \
83 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
84 "
Gunnar Millsc868f922017-02-15 16:01:45 -060085
Brad Bishop811eeec2018-03-09 00:04:00 -050086# These packages are not required with UBI enabled
87${PN}-software-extras = " \
88 obmc-flash-bmc \
89 obmc-mgr-download \
90 "
91
92${PN}-software-extras_df-obmc-ubi-fs = ""
93
Gunnar Millsc868f922017-02-15 16:01:45 -060094SUMMARY_${PN}-software = "Software applications"
95RDEPENDS_${PN}-software = " \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050096 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills30131f72017-05-15 15:40:58 -050097 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Andrew Geissler1f957522018-02-09 12:50:57 -080098 ${VIRTUAL-RUNTIME_obmc-bmc-version} \
Brad Bishop811eeec2018-03-09 00:04:00 -050099 ${${PN}-software-extras} \
Andrew Geissler1f957522018-02-09 12:50:57 -0800100 "
101
Jayanth Othayoth9963d172017-05-08 09:25:05 -0500102SUMMARY_${PN}-debug-collector = "BMC debug collector"
103RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -0500104 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
105 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothd2592492017-07-29 22:28:44 -0500106 phosphor-debug-collector-dreport \
Marri Devender Rao33603922017-10-11 02:22:46 -0500107 phosphor-debug-collector-scripts \
Vishwanatha Subbanna14609cb2017-05-12 23:31:55 +0530108 "
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500109
110SUMMARY_${PN}-settings = "Settings applications"
111RDEPENDS_${PN}-settings = " \
Andrew Geissler78e04542018-02-05 12:02:35 -0800112 ${VIRTUAL-RUNTIME_obmc-settings-mgmt} \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500113 "
Ratan Guptab6de45c2017-07-06 21:09:14 +0530114
115SUMMARY_${PN}-network = "BMC Network Manager"
116RDEPENDS_${PN}-network = " \
117 ${VIRTUAL-RUNTIME_obmc-network-manager} \
118 "
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530119
120SUMMARY_${PN}-user-mgmt = "User management applications"
121RDEPENDS_${PN}-user-mgmt = " \
122 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
123 "