Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML" |
| 3 | PR = "r1" |
Patrick Venture | 8ded78f | 2018-10-01 20:51:32 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 5 | S = "${WORKDIR}/git" |
Patrick Venture | 1a3fdfa | 2018-11-03 09:42:19 -0700 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 10 | inherit pythonnative |
Marri Devender Rao | e341401 | 2017-05-29 01:33:26 -0500 | [diff] [blame] | 11 | inherit phosphor-dbus-yaml |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 14 | DEPENDS += "sdbus++-native" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 15 | |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 16 | SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces" |
Andrew Geissler | a00e63d | 2018-11-03 14:20:22 +0000 | [diff] [blame] | 17 | SRCREV = "a1acf5c6397356ae0f45ba5b9d78638c00b62f3d" |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 18 | |
| 19 | DEPENDS_remove_class-native = "sdbus++-native" |
| 20 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 21 | |
| 22 | PACKAGECONFIG ??= "libphosphor_dbus" |
Brad Bishop | 82f51bf | 2017-02-13 14:28:28 -0500 | [diff] [blame] | 23 | PACKAGECONFIG[libphosphor_dbus] = " \ |
| 24 | --enable-libphosphor_dbus, \ |
| 25 | --disable-libphosphor_dbus, \ |
| 26 | systemd sdbusplus, \ |
| 27 | libsystemd sdbusplus \ |
| 28 | " |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 29 | |
| 30 | PACKAGECONFIG_remove_class-native = "libphosphor_dbus" |
| 31 | PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus" |
| 32 | |
| 33 | BBCLASSEXTEND += "native nativesdk" |