Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 1 | SUMMARY = "FRU properties config for ipmi-fru-parser" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit phosphor-ipmi-fru |
| 7 | |
| 8 | SRC_URI += "file://config.yaml" |
| 9 | |
| 10 | DEPENDS += " \ |
| 11 | mrw-native \ |
| 12 | mrw-perl-tools-native \ |
| 13 | " |
| 14 | |
| 15 | PROVIDES += "virtual/phosphor-ipmi-fru-properties" |
| 16 | |
| 17 | S = "${WORKDIR}" |
| 18 | |
| 19 | do_install() { |
| 20 | DEST=${D}${properties_datadir} |
| 21 | install -d ${DEST} |
| 22 | |
| 23 | ${bindir}/perl-native/perl \ |
| 24 | ${bindir}/gen_fru_properties.pl \ |
| 25 | -m ${datadir}/obmc-mrw/${MACHINE}.xml \ |
| 26 | -c config.yaml \ |
Ratan Gupta | dccf5ad | 2017-03-30 14:32:02 +0530 | [diff] [blame] | 27 | -o ${DEST}/extra-properties.yaml |
Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 28 | } |