Tom Joseph | f2614f9 | 2017-05-08 11:49:10 +0530 | [diff] [blame] | 1 | SUMMARY = "Inventory to Sensor config for non-mrw machines" |
| 2 | PR = "r1" |
Patrick Venture | a34f194 | 2018-11-03 16:36:18 -0700 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Tom Joseph | f2614f9 | 2017-05-08 11:49:10 +0530 | [diff] [blame] | 5 | |
| 6 | inherit native |
| 7 | inherit phosphor-ipmi-host |
Tom Joseph | f2614f9 | 2017-05-08 11:49:10 +0530 | [diff] [blame] | 8 | |
| 9 | PROVIDES += "virtual/phosphor-ipmi-inventory-sel" |
| 10 | |
| 11 | SRC_URI += "file://config.yaml" |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | do_install() { |
| 16 | # This recipe would provide the sample inventory to sensor config |
| 17 | # mapping, for non-mrw machines. |
| 18 | |
| 19 | DEST=${D}${sensor_datadir} |
| 20 | install -d ${DEST} |
| 21 | install config.yaml ${DEST}/invsensor.yaml |
| 22 | } |