blob: 41eb7a3f785374f76c0cf8e5d4dcd2b6b13c7570 [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
5inherit obmc-phosphor-utils
6inherit obmc-phosphor-license
7
Brad Bishop93fb5352015-09-09 03:59:20 +00008PROVIDES = "${PACKAGES}"
9PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -050010 ${PN}-bmc-state-mgmt \
11 ${PN}-chassis-state-mgmt \
Brad Bishop6165ec32016-09-06 22:44:21 -040012 ${PN}-extras \
13 ${PN}-extrasdev \
Adriana Kobylak0bce5322017-11-09 10:39:02 -060014 ${PN}-extrasdevtools \
Brad Bishop11909e02017-05-01 11:54:34 -040015 ${PN}-fan-control \
Brad Bishop46631702017-03-01 16:16:06 -050016 ${PN}-host-state-mgmt \
Brad Bishop45f8b572017-02-01 21:04:14 -050017 ${PN}-inventory \
18 ${PN}-leds \
19 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060020 ${PN}-software \
Andrew Geisslera94faf42017-05-08 15:58:01 -050021 ${PN}-host-check-mgmt \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050022 ${PN}-debug-collector \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050023 ${PN}-settings \
Ratan Guptab6de45c2017-07-06 21:09:14 +053024 ${PN}-network \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053025 ${PN}-user-mgmt \
Brad Bishop93fb5352015-09-09 03:59:20 +000026 "
27
Brad Bishop46631702017-03-01 16:16:06 -050028SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
29RDEPENDS_${PN}-bmc-state-mgmt = " \
30 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
31 "
32
33SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
34RDEPENDS_${PN}-chassis-state-mgmt = " \
35 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
36 "
37
Brad Bishop6165ec32016-09-06 22:44:21 -040038SUMMARY_${PN}-extras = "Extra features"
39RDEPENDS_${PN}-extras = " \
Brad Bishop667938f2017-01-12 21:44:51 -050040 phosphor-rest \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040041 phosphor-dbus-monitor \
Brad Bishop70436da2015-09-16 14:49:27 -040042 "
43
Brad Bishop6165ec32016-09-06 22:44:21 -040044SUMMARY_${PN}-extrasdev = "Development features"
45RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylakeaa56c92016-06-16 14:46:06 -050046 rest-dbus \
47 "
Brad Bishop45f8b572017-02-01 21:04:14 -050048
Adriana Kobylak0bce5322017-11-09 10:39:02 -060049SUMMARY_${PN}-extrasdevtools = "Development tools"
50RDEPENDS_${PN}-extrasdevtools = " \
51 "
52
Brad Bishop11909e02017-05-01 11:54:34 -040053# Use the fan control package group for applications
54# implementing fan control or system fan policy only.
55# Applications that create inventory or sensors should
56# be added those respective package groups instead.
57SUMMARY_${PN}-fan-control = "Fan control"
58RDEPENDS_${PN}-fan-control = " \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050059 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinler39652c82017-05-01 14:29:20 -050060 phosphor-fan-monitor \
Brad Bishop11909e02017-05-01 11:54:34 -040061 "
62
Brad Bishop46631702017-03-01 16:16:06 -050063SUMMARY_${PN}-host-state-mgmt = "Host state management"
64RDEPENDS_${PN}-host-state-mgmt = " \
65 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -050066 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -050067 "
68
Brad Bishop45f8b572017-02-01 21:04:14 -050069SUMMARY_${PN}-inventory = "Inventory applications"
70RDEPENDS_${PN}-inventory = " \
71 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -060072 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop45f8b572017-02-01 21:04:14 -050073 "
74
75SUMMARY_${PN}-leds = "LED applications"
76RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -050077 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
78 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandrane1266ad2017-04-27 05:29:56 -050079 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop45f8b572017-02-01 21:04:14 -050080 "
81
82SUMMARY_${PN}-sensors = "Sensor applications"
83RDEPENDS_${PN}-sensors = " \
84 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
85 "
Gunnar Millsc868f922017-02-15 16:01:45 -060086
Brad Bishop811eeec2018-03-09 00:04:00 -050087# These packages are not required with UBI enabled
88${PN}-software-extras = " \
89 obmc-flash-bmc \
90 obmc-mgr-download \
91 "
92
93${PN}-software-extras_df-obmc-ubi-fs = ""
94
Gunnar Millsc868f922017-02-15 16:01:45 -060095SUMMARY_${PN}-software = "Software applications"
96RDEPENDS_${PN}-software = " \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050097 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills30131f72017-05-15 15:40:58 -050098 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Andrew Geissler1f957522018-02-09 12:50:57 -080099 ${VIRTUAL-RUNTIME_obmc-bmc-version} \
Brad Bishop811eeec2018-03-09 00:04:00 -0500100 ${${PN}-software-extras} \
Andrew Geissler1f957522018-02-09 12:50:57 -0800101 "
102
Jayanth Othayoth9963d172017-05-08 09:25:05 -0500103SUMMARY_${PN}-debug-collector = "BMC debug collector"
104RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -0500105 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
106 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothd2592492017-07-29 22:28:44 -0500107 phosphor-debug-collector-dreport \
Marri Devender Rao33603922017-10-11 02:22:46 -0500108 phosphor-debug-collector-scripts \
Vishwanatha Subbanna14609cb2017-05-12 23:31:55 +0530109 "
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500110
111SUMMARY_${PN}-settings = "Settings applications"
112RDEPENDS_${PN}-settings = " \
Andrew Geissler78e04542018-02-05 12:02:35 -0800113 ${VIRTUAL-RUNTIME_obmc-settings-mgmt} \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500114 "
Ratan Guptab6de45c2017-07-06 21:09:14 +0530115
116SUMMARY_${PN}-network = "BMC Network Manager"
117RDEPENDS_${PN}-network = " \
118 ${VIRTUAL-RUNTIME_obmc-network-manager} \
119 "
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530120
121SUMMARY_${PN}-user-mgmt = "User management applications"
122RDEPENDS_${PN}-user-mgmt = " \
123 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
124 "