Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
| 3 | HOMEPAGE = "http://github.com/openbmc/sdbusplus" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
| 8 | inherit autotools pkgconfig |
Patrick Williams | 5818530 | 2016-11-22 07:01:14 -0600 | [diff] [blame] | 9 | inherit obmc-phosphor-python-autotools |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 10 | |
Nagaraju Goruganti | 78077a5 | 2017-08-22 05:24:26 -0500 | [diff] [blame] | 11 | DEPENDS += " \ |
| 12 | autoconf-archive-native \ |
| 13 | python-inflection-native \ |
| 14 | python-mako-native \ |
| 15 | python-pyyaml-native \ |
| 16 | " |
Brad Bishop | 29dc870 | 2017-01-12 14:06:43 -0500 | [diff] [blame] | 17 | RDEPENDS_sdbus++ += " \ |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 18 | python-inflection \ |
| 19 | python-mako \ |
| 20 | python-pyyaml \ |
| 21 | " |
| 22 | |
Brad Bishop | 32f0a9a | 2017-01-18 13:59:33 -0500 | [diff] [blame] | 23 | # sdbus++ has a handful of runtime dependencies on other python packages. |
| 24 | # Bitbake doesn't do anything with RDEPENDS in native context because |
| 25 | # native context doesn't have packages. |
| 26 | # |
| 27 | # While technically sdbus++ doesn't require its runtime dependencies to be |
| 28 | # installed to build, work around the above native context behavior |
| 29 | # by adding a build dependency so that clients don't have to DEPEND |
| 30 | # on sdbus++ runtime dependencies manually. |
| 31 | |
| 32 | DEPENDS_append_class-native = " \ |
| 33 | python-inflection-native \ |
| 34 | python-mako-native \ |
| 35 | python-pyyaml-native \ |
| 36 | " |
| 37 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 38 | SRC_URI += "git://github.com/openbmc/sdbusplus" |
Andrew Geissler | a022877 | 2018-07-18 16:50:03 -0500 | [diff] [blame] | 39 | SRCREV = "0db800773e6b690a95a11ab4a79d77337f21bf12" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 40 | |
Adriana Kobylak | 178d6b5 | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 41 | PACKAGECONFIG ??= "libsdbusplus transaction" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 42 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
Adriana Kobylak | 178d6b5 | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 43 | PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction" |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 44 | |
| 45 | S = "${WORKDIR}/git" |
| 46 | |
Patrick Williams | 2979202 | 2016-11-22 11:05:11 -0600 | [diff] [blame] | 47 | PROVIDES_prepend = "sdbus++ " |
Brad Bishop | cc01d1a | 2018-02-27 00:30:06 -0500 | [diff] [blame] | 48 | PACKAGE_BEFORE_PN = "sdbus++" |
Patrick Williams | 2979202 | 2016-11-22 11:05:11 -0600 | [diff] [blame] | 49 | FILES_sdbus++_append = " ${bindir}/sdbus++" |
| 50 | PYTHON_AUTOTOOLS_PACKAGE = "sdbus++" |
| 51 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 52 | PACKAGECONFIG_remove_class-native = "libsdbusplus" |
| 53 | PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus" |
| 54 | |
Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 55 | BBCLASSEXTEND += "native nativesdk" |