blob: 81dfa6b37f74c02a0ea29b95c35865cb1cd85f12 [file] [log] [blame]
Matt Spinlerb89b9e72017-04-17 16:34:24 -05001SUMMARY = "Generate fan control YAML from the MRW"
2PR = "r1"
Patrick Venture08c675b2018-11-04 08:14:11 -08003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Matt Spinlerb89b9e72017-04-17 16:34:24 -05005
6inherit native
Matt Spinlerb89b9e72017-04-17 16:34:24 -05007inherit phosphor-fan
Matt Spinler3f6fcbe2017-12-14 13:31:55 -06008inherit mrw-xml
Matt Spinlerb89b9e72017-04-17 16:34:24 -05009
10DEPENDS += " \
11 mrw-native \
12 mrw-perl-tools-native \
13 "
14
15PROVIDES += "virtual/phosphor-fan-control-fan-config"
16
17S = "${WORKDIR}"
18
19do_compile() {
20 ${bindir}/perl-native/perl \
21 ${bindir}/gen_fan_zone_yaml.pl \
Matt Spinler3f6fcbe2017-12-14 13:31:55 -060022 -i ${mrw_datadir}/${MRW_XML} \
Matt Spinlerb89b9e72017-04-17 16:34:24 -050023 -o ${S}/fans.yaml
24}
25
26do_install() {
27 DEST=${D}${control_datadir}
28 install -D ${S}/fans.yaml ${DEST}/fans.yaml
29}