blob: 6f0afc633842124c81269ce47c9daebd016ffcd0 [file] [log] [blame]
Adriana Kobylak59e96d72018-09-24 14:27:15 -05001SUMMARY = "Network Block Device Proxy"
2HOMEPAGE = "https://github.com/openbmc/jsnbd"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8inherit autotools pkgconfig
9
10DEPENDS += "json-c"
11DEPENDS += "udev"
12
Adriana Kobylakaecb1052018-10-03 15:16:29 -050013RDEPENDS_${PN} += "nbd-client"
14
Adriana Kobylak59e96d72018-09-24 14:27:15 -050015S = "${WORKDIR}/git"
16
17SRC_URI = "git://github.com/openbmc/jsnbd"
Andrew Geissler6e39d432019-06-24 08:01:33 +000018SRCREV = "bcc6cc5bcadb20005ae03c8c4a4eb87006f0d222"
Adriana Kobylak88a54ab2018-10-24 13:31:40 -050019
20NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
21
22do_install_append() {
23 install -d ${D}${sysconfdir}/nbd-proxy/
24 install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
25}