Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC python devtools" |
| 2 | DESCRIPTION = "Shortcut scripts for developers." |
| 3 | PR = "r1" |
Patrick Venture | cd03011 | 2018-10-09 19:45:26 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 5 | |
| 6 | inherit skeleton-python |
| 7 | |
| 8 | VIRTUAL-RUNTIME_skeleton_workbook ?= "" |
| 9 | |
| 10 | RDEPENDS_${PN} += "\ |
| 11 | python-dbus \ |
| 12 | python-json \ |
| 13 | python-xml \ |
| 14 | python-pygobject \ |
| 15 | ${VIRTUAL-RUNTIME_skeleton_workbook} \ |
| 16 | " |
| 17 | |
| 18 | SKELETON_DIR = "pytools" |
Andrew Jeffery | e6e3f46 | 2018-02-26 11:25:27 +1030 | [diff] [blame] | 19 | |
| 20 | do_install_append() { |
| 21 | if [ -f ${S}/obmcutil-completion.sh ] |
| 22 | then |
Brad Bishop | d1413ae | 2018-03-01 16:21:40 -0500 | [diff] [blame] | 23 | install -d ${D}${sysconfdir}/profile.d |
| 24 | install -m 0644 -D -t ${D}${sysconfdir}/profile.d ${S}/obmcutil-completion.sh |
Andrew Jeffery | e6e3f46 | 2018-02-26 11:25:27 +1030 | [diff] [blame] | 25 | fi |
| 26 | } |