blob: 1a6959a4c0c1642e0d8d02376aa01842d2612b3f [file] [log] [blame]
Chris Austen213cd2a2015-10-24 19:34:11 -05001SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
2DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
3HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
4PR = "r1"
5
6RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
7
8inherit obmc-phosphor-license
9
10DEPENDS += "systemd \
11 host-ipmid \
12 "
Chris Austen254cb562016-01-23 18:00:11 -060013TARGET_CFLAGS += "-fpic"
Chris Austen213cd2a2015-10-24 19:34:11 -050014
15
16RDEPENDS_${PN} += "libsystemd"
17
18
19
20SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
21
Norman James90f124c2016-03-06 19:44:59 -060022SRCREV = "345932324ce63d42fd88e762cb539c864167b008"
Chris Austen213cd2a2015-10-24 19:34:11 -050023
24FILES_${PN} += "${libdir}/host-ipmid/*.so"
25FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
26
27S = "${WORKDIR}/git"
28
29do_install() {
30 install -m 0755 -d ${D}${libdir}/host-ipmid
31 install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
32}