blob: ae1b24192178836047e3c5b655fa2bd871d92745 [file] [log] [blame]
James Feiste8c0ec92018-10-02 16:45:42 -07001SUMMARY = "Entity Manager"
2DESCRIPTION = "Entity Manager provides d-bus configuration data \
3and configures system sensors"
4
Brad Bishopc497f352020-08-18 19:06:53 -04005SRC_URI = "git://github.com/openbmc/entity-manager.git file://blocklist.json"
Andrew Geisslera4924af2020-10-28 15:21:18 +00006SRCREV = "21608383661285e63e97c0457f55817f6e1d6b92"
James Feiste8c0ec92018-10-02 16:45:42 -07007PV = "0.1+git${SRCPV}"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
11
James Feiste8c0ec92018-10-02 16:45:42 -070012DEPENDS = "boost \
James Feiste8c0ec92018-10-02 16:45:42 -070013 nlohmann-json \
14 sdbusplus \
15 valijson"
16
17S = "${WORKDIR}/git/"
Brad Bishopc9708902020-02-14 14:07:11 -050018inherit meson systemd
Brad Bishop6281b852020-03-18 16:33:02 -040019
Brad Bishop97d49ab2020-03-30 14:16:34 -040020EXTRA_OEMESON = "-Dtests=disabled"
21
Brad Bishop4525a9d2020-08-18 19:30:11 -040022PACKAGECONFIG ??= "ipmi-fru"
Brad Bishop6281b852020-03-18 16:33:02 -040023PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
Brad Bishopc497f352020-08-18 19:06:53 -040024
Brad Bishop4525a9d2020-08-18 19:30:11 -040025EXTRA_ENTITY_MANAGER_PACKAGES = " \
26 ${@bb.utils.contains('PACKAGECONFIG', 'ipmi-fru', 'fru-device', '', d)} \
27 "
28
29PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}"
30
Brad Bishopc497f352020-08-18 19:06:53 -040031do_install_append() {
32 install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
33}
Brad Bishop4525a9d2020-08-18 19:30:11 -040034
35FILES_fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
36
37SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"
38SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service"
39SYSTEMD_SERVICE_fru-device = "xyz.openbmc_project.FruDevice.service"
40SYSTEMD_AUTO_ENABLE_fru-device_ibm-power-cpu = "disable"