blob: 43825f427d96bb3e2f491870890af41bb0be8a38 [file] [log] [blame]
Chris Austen737b35f2015-10-25 00:21:04 -05001SUMMARY = "Phosphor OpenBMC Event Management"
2DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
Chris Austen3fef0762015-10-30 15:59:47 -05003HOMEPAGE = "https://github.com/openbmc/phosphor-event"
Chris Austen737b35f2015-10-25 00:21:04 -05004PR = "r1"
5
6
7inherit obmc-phosphor-license
Brad Bishop745f13b2016-08-30 15:06:19 -04008inherit obmc-phosphor-dbus-service
Chris Austen737b35f2015-10-25 00:21:04 -05009inherit obmc-phosphor-c-daemon
10
Brad Bishopa7156812016-09-06 22:02:03 -040011PROVIDES += "virtual/obmc-event-mgmt"
12RPROVIDES_${PN} += "virtual-obmc-event-mgmt"
13
Patrick Williams8592c8c2016-08-30 12:30:23 -050014TARGET_CXXFLAGS += " -std=c++11 -fpic"
15TARGET_CFLAGS += " -fpic"
Chris Austen737b35f2015-10-25 00:21:04 -050016
Chris Austen3fef0762015-10-30 15:59:47 -050017SRC_URI += "git://github.com/openbmc/phosphor-event"
18
Patrick Williamse43eee72016-08-30 12:30:03 -050019SRCREV = "059b35e1eabdd87ad02b4343692789386c134082"
Chris Austen737b35f2015-10-25 00:21:04 -050020
21RDEPENDS_${PN} += "libsystemd"
22DEPENDS += "systemd"
23
Brad Bishop745f13b2016-08-30 15:06:19 -040024DBUS_SERVICE_${PN} = "org.openbmc.records.events.service"
25SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/eventd/eventd.conf"
Chris Austen737b35f2015-10-25 00:21:04 -050026
27S = "${WORKDIR}/git"
28INSTALL_NAME = "event_messaged"
29
30do_install() {
Chris Austene6be0e32016-02-08 23:00:29 -060031 install -d ${D}/var/lib/obmc/events/
Chris Austen737b35f2015-10-25 00:21:04 -050032 install -m 0755 -d ${D}${sbindir}
Brad Bishop745f13b2016-08-30 15:06:19 -040033 install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/phosphor-eventd
Chris Austen737b35f2015-10-25 00:21:04 -050034}