Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 1 | SUMMARY = "Logging DBUS Object" |
| 2 | DESCRIPTION = "Logging DBUS Object" |
| 3 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools pkgconfig |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit obmc-phosphor-dbus-service |
| 10 | |
| 11 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service" |
| 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "systemd" |
| 15 | DEPENDS += "python-mako-native" |
| 16 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 17 | DEPENDS += "sdbusplus sdbusplus-native" |
Adriana Kobylak | a6fc67f | 2017-01-30 20:30:00 -0600 | [diff] [blame] | 18 | RDEPENDS_${PN} += "sdbusplus" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 19 | PROVIDES += "virtual/obmc-logging-mgmt" |
| 20 | RPROVIDES_${PN} += "virtual-obmc-logging-mgmt" |
| 21 | |
| 22 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Patrick Williams | 6898826 | 2017-02-06 08:50:03 -0600 | [diff] [blame] | 23 | SRCREV = "f542ba8271617afa73117a6a194572719760d734" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 24 | |
| 25 | S = "${WORKDIR}/git" |
| 26 | |