blob: 33a9ca081eab98a76c67e2030c9b328d381a5fc0 [file] [log] [blame]
Hariharasubramanian R5c3fd8a2016-02-10 13:48:33 -06001SUMMARY = "User DBUS object"
2DESCRIPTION = "User DBUS object"
3HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
4PR = "r1"
5
6inherit obmc-phosphor-license
Adriana Kobylakf1cd2b52016-02-11 16:31:21 -06007inherit obmc-phosphor-user-mgmt
Hariharasubramanian R5c3fd8a2016-02-10 13:48:33 -06008inherit obmc-phosphor-systemd
9
10RDEPENDS_${PN} += "python-dbus python-pygobject python-pexpect"
11
12SRC_URI += "git://github.com/openbmc/phosphor-networkd"
13
Patrick Williamsc89ef962016-08-13 09:04:18 -050014SRCREV = "75757c08579200677391f5319aee68cafcae0bf1"
Hariharasubramanian R5c3fd8a2016-02-10 13:48:33 -060015
16S = "${WORKDIR}/git"
Adriana Kobylakf1cd2b52016-02-11 16:31:21 -060017INSTALL_NAME = "userman.py"
Hariharasubramanian R5c3fd8a2016-02-10 13:48:33 -060018
Patrick Williamsaf6d09d2016-08-15 15:52:09 -050019# Since base_do_compile finds a makefile (from networkd) it tries to
20# compile. Short-circuit that because we just need to copy a python
21# file in this package.
22do_compile() {
23 :
24}
25
Hariharasubramanian R5c3fd8a2016-02-10 13:48:33 -060026do_install() {
Adriana Kobylakf1cd2b52016-02-11 16:31:21 -060027echo "***installing $INSTALL_NAME"
Hariharasubramanian R5c3fd8a2016-02-10 13:48:33 -060028 install -d ${D}/${sbindir}
Adriana Kobylakf1cd2b52016-02-11 16:31:21 -060029 install ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-userd
Hariharasubramanian R5c3fd8a2016-02-10 13:48:33 -060030}
31