blob: 96a12392d83c3a8d3ca6b9e61c60020103181303 [file] [log] [blame]
Patrick Williamsf6f2edb2017-01-30 11:05:56 -06001SUMMARY = "Phosphor DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
Marri Devender Raoe3414012017-05-29 01:33:26 -050010inherit phosphor-dbus-yaml
Patrick Williamsf6f2edb2017-01-30 11:05:56 -060011
12DEPENDS += "autoconf-archive-native"
Brad Bishop5f7b1712017-02-02 20:49:22 -050013DEPENDS += "sdbus++-native"
Patrick Williamsf6f2edb2017-01-30 11:05:56 -060014
Patrick Williamsf6f2edb2017-01-30 11:05:56 -060015SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
Andrew Geisslerb104c552018-01-30 18:55:08 +000016SRCREV = "862ac59a52945ada1a6e641ab625dc18ec614192"
Brad Bishop5f7b1712017-02-02 20:49:22 -050017
18DEPENDS_remove_class-native = "sdbus++-native"
19DEPENDS_remove_class-nativesdk = "sdbus++-native"
20
21PACKAGECONFIG ??= "libphosphor_dbus"
Brad Bishop82f51bf2017-02-13 14:28:28 -050022PACKAGECONFIG[libphosphor_dbus] = " \
23 --enable-libphosphor_dbus, \
24 --disable-libphosphor_dbus, \
25 systemd sdbusplus, \
26 libsystemd sdbusplus \
27 "
Brad Bishop5f7b1712017-02-02 20:49:22 -050028
29PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
30PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
31
32BBCLASSEXTEND += "native nativesdk"