blob: e41da0be31dba704810c2291f255599a7c9720a1 [file] [log] [blame]
vishwabmc1bf499d2015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc1bf499d2015-10-09 15:51:50 +05303PR = "r1"
Patrick Venturef30b8842018-10-21 08:27:22 -07004PV = "1.0+git${SRCPV}"
Patrick Venture64329372018-11-03 09:42:59 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
vishwabmc1bf499d2015-10-09 15:51:50 +05307
Brad Bishop7ee71462016-08-19 09:02:54 -05008RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen213cd2a2015-10-24 19:34:11 -05009
Matthew Barth302592f2016-08-16 16:51:35 -050010inherit autotools pkgconfig
Patrick Ventured3dd0942017-12-22 14:36:07 -080011inherit obmc-phosphor-ipmiprovider-symlink
Patrick Williamsf7714062015-10-15 15:20:20 -050012inherit obmc-phosphor-sdbus-service
Patrick Ventured3dd0942017-12-22 14:36:07 -080013inherit obmc-phosphor-systemd
Ratan Guptab92d0ec2017-03-06 17:05:11 +053014inherit phosphor-ipmi-host
15inherit pythonnative
vishwabmc1bf499d2015-10-09 15:51:50 +053016
Brad Bishop7f2ade02018-01-26 22:11:36 -050017def ipmi_whitelists(d):
18 whitelists = d.getVar(
19 'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
20 whitelists = whitelists.split()
21 whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
22 return ' '.join(whitelists)
23
Patrick Ventured3dd0942017-12-22 14:36:07 -080024DEPENDS += "autoconf-archive-native"
David Cobbley1dc78fb2017-11-21 16:17:40 -080025DEPENDS += "nlohmann-json"
Patrick Ventured3dd0942017-12-22 14:36:07 -080026DEPENDS += "obmc-targets"
Brad Bishop7f2ade02018-01-26 22:11:36 -050027DEPENDS += "${@ipmi_whitelists(d)}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080028DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak17885c22017-02-17 08:21:42 -060029DEPENDS += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040030DEPENDS += "phosphor-mapper"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053031DEPENDS += "sdbusplus"
Patrick Ventured3dd0942017-12-22 14:36:07 -080032DEPENDS += "sdbus++-native"
Tom Josephc32034f2019-02-04 03:54:06 -060033DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050034DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
Patrick Ventured3dd0942017-12-22 14:36:07 -080035DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Andrew Geisslera561ec92018-09-25 19:50:20 +000036DEPENDS += "boost"
Patrick Venture12a94a82018-11-07 17:48:53 -080037DEPENDS += "sdeventplus"
Ratan Guptab92d0ec2017-03-06 17:05:11 +053038
Andrew Jeffery381e1e92018-04-06 14:13:14 +093039VIRTUAL-RUNTIME_ipmi-config ?= "phosphor-ipmi-config"
40
Adriana Kobylak17885c22017-02-17 08:21:42 -060041RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040042RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller II611e3ff2016-03-04 15:29:29 -060043RDEPENDS_${PN} += "clear-once"
Patrick Venture98fa9612019-03-28 09:09:13 -070044RDEPENDS_${PN} += "phosphor-network"
Vishwanatha Subbanna78bc5422016-11-10 21:52:46 +053045RDEPENDS_${PN} += "phosphor-time-manager"
Andrew Jeffery381e1e92018-04-06 14:13:14 +093046RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_ipmi-config}"
Vishwanatha Subbanna55c545a2017-06-12 13:09:10 +053047RDEPENDS_${PN} += "virtual/obmc-watchdog"
Patrick Venture68f12612019-04-30 10:26:34 -070048RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-bmc-state-manager}"
Patrick Venture00e88bf2019-05-03 07:51:58 -070049RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-bmc-version}"
Patrick Venturef5dd0312019-05-03 07:53:57 -070050RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-bmc-updater}"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053051
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053052inherit useradd
53
54USERADD_PACKAGES = "${PN}"
55# add ipmi group
56GROUPADD_PARAM_${PN} = "ipmi"
57
Vishwanatha Subbanna35318402017-03-31 14:41:11 +053058SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
59
Andrew Geissler78e04542018-02-05 12:02:35 -080060RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-settings-mgmt}"
61
vishwabmc1bf499d2015-10-09 15:51:50 +053062
Marri Devender Rao52a9f2d2017-06-08 00:47:54 -050063require ${PN}.inc
Chris Austen213cd2a2015-10-24 19:34:11 -050064
Tom Josephf07ae012017-02-20 12:01:43 +053065# Setup IPMI Whitelist Conf files
66WHITELIST_CONF = " \
Patrick Williamsf11f0152017-02-24 13:04:06 -060067 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Josephf07ae012017-02-20 12:01:43 +053068 ${S}/host-ipmid-whitelist.conf \
69 "
70EXTRA_OECONF = " \
Ratan Guptab92d0ec2017-03-06 17:05:11 +053071 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephc32034f2019-02-04 03:54:06 -060072 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050073 FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
Tom Josephf07ae012017-02-20 12:01:43 +053074 "
Brad Bishopbb60cff2019-06-09 22:57:35 -040075EXTRA_OECONF_append = " \
76 WHITELIST_CONF="${WHITELIST_CONF}" \
77 "
Tom Josephf07ae012017-02-20 12:01:43 +053078
vishwabmc1bf499d2015-10-09 15:51:50 +053079S = "${WORKDIR}/git"
80
Andrew Jeffery381e1e92018-04-06 14:13:14 +093081SRC_URI += "file://merge_yamls.py "
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -050082
Vernon Mauery595c7382018-07-30 15:49:09 -070083HOSTIPMI_PROVIDER_LIBRARY += "libipmi20.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053084HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
William A. Kennington IIIc426a982018-12-19 14:53:22 -080085HOSTIPMI_PROVIDER_LIBRARY += "libusercmds.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053086
Vernon Mauery595c7382018-07-30 15:49:09 -070087NETIPMI_PROVIDER_LIBRARY += "libipmi20.so"
William A. Kennington IIIc426a982018-12-19 14:53:22 -080088NETIPMI_PROVIDER_LIBRARY += "libusercmds.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053089
Matthew Barth302592f2016-08-16 16:51:35 -050090FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080091FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053092FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
93FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop3b524cf2016-09-06 13:03:39 -040094
Andrew Geisslerafc510f2017-01-04 11:11:50 -060095# Soft Power Off
Andrew Geisslerd40db752017-05-11 16:16:27 -050096# install the soft power off service in the host shutdown target
97SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
98SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
99SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
100SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500101
102#Collect all hardcoded sensor yamls from different recipes and
103#merge all of them with sensor.yaml.
104python do_merge_sensors () {
105 import subprocess
106
107 # TODO: Perform the merge in a temporary directory?
108 workdir = d.getVar('WORKDIR', True)
109 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
110 sensorsdir = d.getVar('sensor_datadir', True)
111 sensorsdir = sensorsdir[1:]
112 sensorsdir = os.path.join(nativedir, sensorsdir)
113 cmd = []
114 cmd.append(os.path.join(workdir, 'merge_yamls.py'))
115 cmd.append(os.path.join(sensorsdir, 'sensor.yaml'))
116
117 if os.stat(os.path.join(sensorsdir, 'sensor.yaml')).st_size == 0:
118 return
119 fetch = bb.fetch2.Fetch([], d)
Kun Yie6bd58c2017-10-09 23:17:08 -0700120 override_urls = [url for url in fetch.urls if url.endswith('.hardcoded.yaml')]
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500121 for url in override_urls:
122 bb.debug(2, 'Overriding with source: ' + url)
123 local_base = os.path.basename(fetch.localpath(url))
124 filename = os.path.join(workdir, local_base)
125 cmd.append(filename)
126
127 # Invoke the script and don't catch any resulting exception.
128 subprocess.check_call(cmd)
129}
Andrew Jeffery381e1e92018-04-06 14:13:14 +0930130
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500131# python-pyyaml-native is installed by do_configure, so put this task after
132addtask merge_sensors after do_configure before do_compile