blob: d0cf359d6d4c7042289b5aab4d05855b24094acf [file] [log] [blame]
Adriana Kobylakfa7c2122015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
Brad Bishop5a4b9532015-10-21 20:24:23 -04008inherit obmc-phosphor-chassis-mgmt
9inherit obmc-phosphor-event-mgmt
10inherit obmc-phosphor-fan-mgmt
11inherit obmc-phosphor-flash-mgmt
12inherit obmc-phosphor-policy-mgmt
13inherit obmc-phosphor-sensor-mgmt
14inherit obmc-phosphor-system-mgmt
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040015
16DEPENDS += "glib-2.0"
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040017RDEPENDS_${PN} += "python-subprocess python-tftpy"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040018SRC_URI += "git://github.com/openbmc/skeleton"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040019
Norman Jamesb3422792015-10-20 16:28:16 -050020SRCREV = "47750bc1c06aebda189f2e8d7862c9d9b9ffe35b"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040021
22S = "${WORKDIR}/git"
23
24do_compile() {
25 oe_runmake all
26}
27
28do_install() {
29 install -d ${D}/${sbindir} ${D}${libdir}
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040030 for i in ${S}/bin/*.py ${S}/bin/*.exe; do
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040031 install $i ${D}/${sbindir}
32 done
33 install ${S}/bin/libopenbmc_intf.so ${D}/${libdir}
34}